summaryrefslogtreecommitdiff
path: root/app-text/libgepub/libgepub-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-text/libgepub/libgepub-0.6.0.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-text/libgepub/libgepub-0.6.0.ebuild')
-rw-r--r--app-text/libgepub/libgepub-0.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/libgepub/libgepub-0.6.0.ebuild b/app-text/libgepub/libgepub-0.6.0.ebuild
new file mode 100644
index 000000000000..5d6e53a2c0a0
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_use introspection)
+}