summaryrefslogtreecommitdiff
path: root/app-text/libetonyek/libetonyek-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-text/libetonyek/libetonyek-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-text/libetonyek/libetonyek-9999.ebuild')
-rw-r--r--app-text/libetonyek/libetonyek-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-text/libetonyek/libetonyek-9999.ebuild b/app-text/libetonyek/libetonyek-9999.ebuild
index a9b34322cd7f..7493c2947bb9 100644
--- a/app-text/libetonyek/libetonyek-9999.ebuild
+++ b/app-text/libetonyek/libetonyek-9999.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == *9999 ]]; then
+ MDDS_VER="9999"
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
inherit autotools git-r3
else
+ MDDS_VER="2.0"
SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
@@ -26,7 +28,7 @@ RDEPEND="
app-text/liblangtag
dev-libs/librevenge
dev-libs/libxml2
- >=dev-util/mdds-1.5:1=
+ >=dev-util/mdds-${MDDS_VER}:1=
sys-libs/zlib
"
DEPEND="${RDEPEND}
@@ -45,6 +47,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--disable-werror
+ --with-mdds="${MDDS_VER}"
$(use_with doc docs)
$(use_enable static-libs static)
$(use_enable test tests)