summaryrefslogtreecommitdiff
path: root/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild')
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
index ea6d68087c1a..c83aaa454cd3 100644
--- a/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs flag-o-matic
DESCRIPTION="Font utilities for eg manipulating OTF"
-SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
-HOMEPAGE="http://www.lcdf.org/type/#typetools"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
+HOMEPAGE="https://lcdf.org/type/#typetools"
+SRC_URI="https://lcdf.org/type/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+kpathsea"
RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_configure() {
- use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ use kpathsea && has_version 'dev-libs/kpathsea' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
econf $(use_with kpathsea)
}