summaryrefslogtreecommitdiff
path: root/app-text/krop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
commitccf84bcd604130256d1377cd58f0a634ae6ee20f (patch)
treef42a709e0c7805183f5680883bc76dc935b7a0cc /app-text/krop
parentc85a90f90521c7e11d618b527d6630cc64cecbd4 (diff)
gentoo resync : 28.12.2017
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/Manifest2
-rw-r--r--app-text/krop/krop-0.4.13.5.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/app-text/krop/Manifest b/app-text/krop/Manifest
index 6812c9d2c582..b7b23828e0d3 100644
--- a/app-text/krop/Manifest
+++ b/app-text/krop/Manifest
@@ -1,3 +1,5 @@
+DIST krop-0.4.13.5.tar.gz 40079 BLAKE2B 9d3505f7d9cbf0eef4ec7a28928f14940e6c0a2fd4499b6c5896fde7b3f7b8a0b84ddc4f9c7735ee348f89e9924a7b8f69a3d4dbfaa4668ac770a0fe8404d469 SHA512 218eb3e256dabcacc53af62b2e704031bd21bedacf2599c4aed7ee3b3847b35741c921a08137b7b6e7295ddfc7f87f4ffbf9d3fec3fb137d1ce36e3945dc6129
DIST krop-0.4.13.tar.gz 36654 BLAKE2B 87c6ae2435ba7f4f7d5d8ad19f4804a1e45b9bb44bef7e03b46cf6e3c1a59cdf5dfd81a7a7d8c26a0f09b75e7d3dcdfa28b4795a786f8eb06d95881eacfc7cee SHA512 2d2af25124b45108715eb90344a5683adbda4c788bd419360b641e9f47553fe143a40205a44af9b3e4db6df4148b3328547e774f24b5c7c0fd23c9206e8a14b2
+EBUILD krop-0.4.13.5.ebuild 713 BLAKE2B 4b18cd8a175c62ea18e6fb7864bdc2995d54b27185ec4754538bdcb2c2176931532490d34f3a13f246c2d29f8c68c642fb23175e2328d1dfc79275342cf8c9c8 SHA512 deb6d8d593a350a026cb26ce9f425b736938ebd694686dd2b9fc954df131d6ca3921222cf500d681115c6163108448b3f049d8f8b2cefb3c971c614055c6465a
EBUILD krop-0.4.13.ebuild 609 BLAKE2B a740a07ac30a2c7f3e2120f29eb9d54793b1b17705b0c50654f52a3e52face3cfd1d18d2acca69708bc8e2115cd31a10d708561e8d9aabc2b5adef0653966c2e SHA512 a0dd10fa9ede60ae319817da497cb5be4256e3fa2d6d98d1998f8f93fd88609ff31c80d8446d3757c501d338b48eb68008a63046667255a93583637010ec65b8
MISC metadata.xml 333 BLAKE2B b62d23170b13a4d2375de72955c2708368a34435f022231b829b19b60c9f38a1546ec62887dae545691eb1df45998ab7810aa58df3b94729632991e49c4c098f SHA512 30ec13878bbe3b50c90f1849bbc5bf0f8dc05bf1b6a8f79695590f48c76618eef4666965b8130d1909db3c960a43d3149dba525017f342ce9635afc530b873f0
diff --git a/app-text/krop/krop-0.4.13.5.ebuild b/app-text/krop/krop-0.4.13.5.ebuild
new file mode 100644
index 000000000000..23966dc8cf43
--- /dev/null
+++ b/app-text/krop/krop-0.4.13.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+#SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~huettel/distfiles/${P}.tar.gz"
+# this is a snapshot of the qt5 branch
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}