summaryrefslogtreecommitdiff
path: root/app-text/krop/krop-0.6.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 05:36:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 05:36:05 +0100
commit4bbcd26e7cb1908fb98bb318bfaa13ea9e32d860 (patch)
tree39e9258a61ef296b0e5afba0c7dc2557891487c4 /app-text/krop/krop-0.6.0-r2.ebuild
parent47d5e233005d470dbd431a280e64ce6073fc7149 (diff)
gentoo auto-resync : 10:04:2023 - 05:36:05
Diffstat (limited to 'app-text/krop/krop-0.6.0-r2.ebuild')
-rw-r--r--app-text/krop/krop-0.6.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/krop/krop-0.6.0-r2.ebuild b/app-text/krop/krop-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..830a5e54f24d
--- /dev/null
+++ b/app-text/krop/krop-0.6.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
+else
+ SRC_URI="https://github.com/arminstraub/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-links.patch"
+ "${FILESDIR}/${P}-pikepdf.patch"
+)
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}