summaryrefslogtreecommitdiff
path: root/app-text/kbibtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 01:09:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 01:09:44 +0000
commite33383d972aad8129fd4c1ee2b87f529f6efa8e9 (patch)
tree6a41fd6c2b9a997737264687637da3a9eee3d9d6 /app-text/kbibtex
parent89aeb05c8da1b0c32fb9d0cd5d202763780d5d5a (diff)
gentoo auto-resync : 24:11:2022 - 01:09:44
Diffstat (limited to 'app-text/kbibtex')
-rw-r--r--app-text/kbibtex/Manifest3
-rw-r--r--app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch28
-rw-r--r--app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch28
-rw-r--r--app-text/kbibtex/kbibtex-0.9.2-r1.ebuild84
4 files changed, 143 insertions, 0 deletions
diff --git a/app-text/kbibtex/Manifest b/app-text/kbibtex/Manifest
index f813d14d0316..764d7bbf0fe1 100644
--- a/app-text/kbibtex/Manifest
+++ b/app-text/kbibtex/Manifest
@@ -1,3 +1,6 @@
+AUX kbibtex-0.9.2-fix-crash-w-newer-Qt.patch 1014 BLAKE2B c283889e375a09be741d6e8f5ef1dc3d5f37f1dd8d2a0b5418220bc660410f1e80e0a3efeb82bc761d9049cd19c2376fa6e729fdf22b03396262d14d88f5587c SHA512 9144a537c7b5e58c3ed795cb173ad66e37d6bb038ad30cd279b4637e60b6760f4c3d9519c8d159dcfe1558b4070c3bfdb989b97e58c449d26eeb0849324d5562
+AUX kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch 984 BLAKE2B c6db4643c03cb72a735751c62195f878d9346638d6675520de2aa16f4a33f7235d248c268abf0ca5abd1d0eddb1e558355e5c637ca1e0e6550c42b4e8ec81253 SHA512 375e2e642a02cd2144fd4fc854e8a2e0e882535a4785771ac154f9bb33816af98527f8c77a86b3228375acb3cbca246c143ed14096d9823a5d87dc1945b9237a
DIST kbibtex-0.9.2.tar.xz 4196896 BLAKE2B 198b9a44f1aa19aa0f33f5abe6bcd135e5367ccacbc1d947fcdca531259d8b0ff3f1a53dacd8ce660691ea0ca709e5873adfbd79d01fe318fdfa273234d97938 SHA512 b733339f21fac0be3125e375d59f9060514107532372504902240e4e744e2f62cdff73ef0ea267e96f1e58e15ce917d1d1fdd7a3811a89493e0caedc877ca63a
+EBUILD kbibtex-0.9.2-r1.ebuild 2175 BLAKE2B 07b413b66a408d86ffa8fa69f3a7b429c711ba5ced9aece45fdb7725d2d8bea7897e2d6d9e7839eecadb1d47cbe6bdff6bd8b8dd20e96ed916edc858921c0e66 SHA512 111036e2f250f4880d38aad95a0cdd2d09fe58a21c89b7b9e204e01e8734aa8840b07b032f30a0e1b50b18f269ab4ec56e90c878035087e8ed2faa212ed5dc4e
EBUILD kbibtex-0.9.2.ebuild 2044 BLAKE2B 06d4fef041b58ee933fd835116656195e03c5a36352020e4a7a27bb63642668ef98068d703096c07d617db68d1bf70325183d9208a296bf1c616ac622ead4c9d SHA512 8e530f8eacb142c2d444912d63f2c3d1da14ecae90d4981ff6b57cfa46b83eaec450ae0eb2f09b1b2197ff87b207516a237ea0c827c12caa801e841f7c3c11d6
MISC metadata.xml 509 BLAKE2B 3543de8d45cd889e8789bfa26154243b90c679126cb37e4a6701bb766dc0a72a39c5c14830dd3dca77b735532d10dc6d513c953bb3268767ea66599eb689b831 SHA512 5f8aeb6e149e2dbad6e06d085afc75d4a04117921e2a5897023a110a9aea2bd2916691c2d43f8f3bd0f575e12175a5a3da1a61fc000c5458aef7b1ebdb11306a
diff --git a/app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch b/app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch
new file mode 100644
index 000000000000..91cc51f9303c
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch
@@ -0,0 +1,28 @@
+From 84b0551eb141b3a7904ceec158d040200c995023 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Thu, 8 Apr 2021 22:07:15 +0200
+Subject: [PATCH] Fix crash with newer Qt versions
+
+Assign m_internalModel before calling into
+QSortFilterProxyModel::setSourceModel since that can end up calling filterAcceptsRow
+---
+ src/gui/file/sortfilterfilemodel.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gui/file/sortfilterfilemodel.cpp b/src/gui/file/sortfilterfilemodel.cpp
+index 73707cec..87657aa2 100644
+--- a/src/gui/file/sortfilterfilemodel.cpp
++++ b/src/gui/file/sortfilterfilemodel.cpp
+@@ -40,8 +40,8 @@ SortFilterFileModel::SortFilterFileModel(QObject *parent)
+
+ void SortFilterFileModel::setSourceModel(QAbstractItemModel *model)
+ {
+- QSortFilterProxyModel::setSourceModel(model);
+ m_internalModel = dynamic_cast<FileModel *>(model);
++ QSortFilterProxyModel::setSourceModel(model);
+ }
+
+ FileModel *SortFilterFileModel::fileSourceModel() const
+--
+GitLab
+
diff --git a/app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch b/app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch
new file mode 100644
index 000000000000..fdc42d97810b
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch
@@ -0,0 +1,28 @@
+From 1153930536abe9f0331acef67dc40b18210eb07e Mon Sep 17 00:00:00 2001
+From: Thomas Fischer <fischer@unix-ag.uni-kl.de>
+Date: Sat, 1 Oct 2022 23:15:52 +0200
+Subject: [PATCH] Fix creation of URL from user input
+
+... when opening a document associated with a bibliographic entry.
+
+BUG: 459150
+---
+ src/parts/part.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/parts/part.cpp b/src/parts/part.cpp
+index 5324647f..9dc35d1c 100644
+--- a/src/parts/part.cpp
++++ b/src/parts/part.cpp
+@@ -914,7 +914,7 @@ void KBibTeXPart::elementViewDocumentMenu(QObject *obj)
+ QString text = static_cast<QAction *>(obj)->data().toString(); ///< only a QAction will be passed along
+
+ /// Guess mime type for url to open
+- QUrl url(text);
++ QUrl url{QUrl::fromUserInput(text)};
+ QMimeType mimeType = FileInfo::mimeTypeForUrl(url);
+ const QString mimeTypeName = mimeType.name();
+ /// Ask KDE subsystem to open url in viewer matching mime type
+--
+GitLab
+
diff --git a/app-text/kbibtex/kbibtex-0.9.2-r1.ebuild b/app-text/kbibtex/kbibtex-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..e8d349aaa433
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-0.9.2-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+KFMIN=5.82.0
+QTMIN=5.15.5
+inherit ecm kde.org optfeature
+
+DESCRIPTION="BibTeX editor to edit bibliographies used with LaTeX"
+HOMEPAGE="https://apps.kde.org/kbibtex/ https://userbase.kde.org/KBibTeX"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/KBibTeX/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="5"
+IUSE="webengine zotero"
+
+RESTRICT="test"
+
+DEPEND="
+ app-text/poppler[qt5]
+ dev-libs/icu:=
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ virtual/tex-base
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:5[widgets] )
+ zotero? (
+ >=app-crypt/qca-2.3.0:2[qt5(+)]
+ dev-libs/qoauth:5
+ )
+"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-crash-w-newer-Qt.patch"
+ "${FILESDIR}/${P}-fix-creation-w-url-from-user-input.patch" # KDE-bug 459150
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebKitWidgets=ON
+ $(cmake_use_find_package webengine Qt5WebEngineWidgets)
+ $(cmake_use_find_package zotero Qca-qt5)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "PDF or PostScript document previews" "kde-apps/okular:${SLOT}"
+ fi
+ ecm_pkg_postinst
+}