summaryrefslogtreecommitdiff
path: root/app-text/jabref-bin/jabref-bin-3.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/jabref-bin/jabref-bin-3.8.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-3.8.2.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-3.8.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-3.8.2.ebuild b/app-text/jabref-bin/jabref-bin-3.8.2.ebuild
new file mode 100644
index 000000000000..cefa6107ab82
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-3.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://www.jabref.org/"
+# SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+SRC_URI="https://github.com/JabRef/jabref/releases/download/v${PV}/JabRef-${MY_PV}.jar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ unzip ${A} images/icons/JabRef-icon-48.png || die
+}
+
+src_install() {
+ java-pkg_newjar "JabRef-${MY_PV}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/icons/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+}