summaryrefslogtreecommitdiff
path: root/app-text/jabref-bin/jabref-bin-3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/jabref-bin/jabref-bin-3.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-3.7.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-3.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-3.7.ebuild b/app-text/jabref-bin/jabref-bin-3.7.ebuild
new file mode 100644
index 000000000000..1e671d607b1b
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-3.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://www.jabref.org/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ app-arch/unzip
+"
+RDEPEND="
+ >=virtual/jre-1.8
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ unzip ${A} images/icons/JabRef-icon-48.png || die
+}
+
+src_install() {
+ java-pkg_newjar "JabRef-${MY_PV}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/icons/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+}