summaryrefslogtreecommitdiff
path: root/app-text/iso-codes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 03:21:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 03:21:00 +0000
commitf9c971dedd369d9f45a38f3fae51467e864f5324 (patch)
tree3c8d363095907252d898e4b5d3abf96736ab529b /app-text/iso-codes
parentb6ed1e2a15cd8b0ad5c573cbfee3576fa5ee29a4 (diff)
gentoo auto-resync : 07:11:2022 - 03:21:00
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/Manifest2
-rw-r--r--app-text/iso-codes/iso-codes-4.12.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 8ed22e012ffa..84cee52f52d0 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,3 +1,5 @@
DIST iso-codes-v4.11.0.tar.gz 14756251 BLAKE2B dd3bc5bae4def6338527a9c7c41f0ef9603eb2a2a7e4e2a95399bc4891a0d66fa323bb1f960263662cd6b4a42902defede64ad732f4a894d3073a7a68b5b9f80 SHA512 524be572c2505b0b2d55a7a0dd8d6bdff68edbc89c569652b11070cc6412881c98ea66a001193f1540153d44d6b41d921444a1d1a2bde6929bbe445eb369ea3e
+DIST iso-codes-v4.12.0.tar.gz 14977180 BLAKE2B 23590e9a4f246a0879e68c521ae7f72f4dd8d41ef85e7b6efaa4e4a29b7bf2e45d5e200ae14523e4ef8d3d4c8f45e783d4231a2a1c679be1898aa04528da30d3 SHA512 d0cdac626728e4de7c5bb2f8edd968a29380d49ba2b43ebe3820756591e46d4301859da7961ec9fc9e6832e18a9a0d5562ec02dd3d8a52bec7f7cbfc3190869e
EBUILD iso-codes-4.11.0.ebuild 2644 BLAKE2B c8b95785c6ae2a195514e3fe98dd1118da05d82b1a9293b53117cbc13206dca1e1809286dae55acfd7d901779c4b0ba9f1720f599eddff56e04fc8a03d7195be SHA512 047f704e4a96c72e9f8b96a65af3119806f4dba691f5b55902381d250b07b32a6d54c252b41f42677b9135fc36040563424ef288703bb32f573fc16a31d7647d
+EBUILD iso-codes-4.12.0.ebuild 2657 BLAKE2B f4bfa0e5e17ac340a84f42db606b691396258cf08203c6c7d4a8d9031839858d374fbae7d1a749a65d763e72d058ba44e9ca01f83e97da4b292d173f9bf2d290 SHA512 96ab7636b470f744f4c4a7178b1bd8a3935b356f99034d350878dbdfa4536e9ce96ce09c636b08165430651fd04d5628af26d7a8af73670948625f73586264b5
MISC metadata.xml 481 BLAKE2B e19ee7de8b2de3aa09f97bb7eb4247ba2979614d768c0dd92a8cc131269e46a560baa1c0ea8fcceb49073efb1b890cd54d939c16ac7412413983a19083f05337 SHA512 f1e20f870fabd59d97ca612c3db3443a6a1544de3b03f12fe0c9c44a1740b06bf38c394b489738e60b22fa0797379d24c0ec8371efa067873910ba39fe30f194
diff --git a/app-text/iso-codes/iso-codes-4.12.0.ebuild b/app-text/iso-codes/iso-codes-4.12.0.ebuild
new file mode 100644
index 000000000000..dd05fb137f64
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.12.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pa_PK pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hans zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( CHANGELOG.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}