summaryrefslogtreecommitdiff
path: root/app-text/iso-codes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-10 03:03:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-10 03:03:09 +0000
commitbe94ae04eee564451203d45977c2ef7c7ace1580 (patch)
tree616ffc0ad9aee18dc7d5e9e62bf62394e8e520ba /app-text/iso-codes
parent2be329ae14bbf99f0fc4de7567e2386bbb529fdc (diff)
gentoo auto-resync : 10:11:2024 - 03:03:09
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/Manifest2
-rw-r--r--app-text/iso-codes/iso-codes-4.17.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index c984f2633c4c..cef69395c6ea 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,3 +1,5 @@
DIST iso-codes-v4.16.0.tar.gz 15163129 BLAKE2B 8fcdb3c12c502c1e14169765db9c9dd7778fc5d4bb0da37aa6b27efeebd5ce9f3e825e5b1a7ae8d659babf2d6b9124af08b40ed8a2a1235e88df50be9c204ca5 SHA512 04d93eb37ff309c850a1af6d4cf6bb92a16e25ee35ee12e16325f6e7b476ba40bbf5d11e2f4c425111220480911b1dbc9e244189ea7487f1f0ea4dbce2307c96
+DIST iso-codes-v4.17.0.tar.gz 15459699 BLAKE2B b788e7b9f48e76667e2a7e97367faf7f5229ce66ba1b2d4e458620af4cc189f026b76c580607f7d95b2adda319137964d6e95e683f9363f3825a71c8c6792db9 SHA512 9731270513aa42bda96f277528cf40a47ccdbf7c864ba8a9015f1007ef79cb16aaed0b1c3dd18fca30c923a45e0906f0cc5366fabb85e144fcfeaf82b1943a41
EBUILD iso-codes-4.16.0.ebuild 2632 BLAKE2B 80304a87778292a33a2053700eddd2ac240aea80ff90543d61826029af18ef7d56a6e8e53e8215f419047aa2548b58bd18dfd351cb4ec9a3a28c5482fb105df8 SHA512 2977d4f436dafc35360ee23755cd53250668b8c0db639d42b2bb2504d549205f46369b6dcdfd22ec750f7d39f32b7df8efb7ea74b5c366b260066f05b7dc672e
+EBUILD iso-codes-4.17.0.ebuild 2639 BLAKE2B 4d32ea8b56546920fdd172ecce08ae6e6449e8688ca0b71d39c19fec121ef2267973f504e04b96d55e873cc21b138c57d127c619911cb8d8cf326660c34236b4 SHA512 5ae92a14f94ac46a18334ada639568f8ec92623c279c17e52dcdb7905cbd8f25221cb9c3c342b57ceae80b997985f2d24a50c31675d12fb5afe2773b9146a1cb
MISC metadata.xml 505 BLAKE2B d499c1a01fb2183ec86fcc3ca7af98dc8a2da444babb8a8234a1864093a67d0c247f68330bfd5625e01182bb181a97d35b42c74a8706cf61b2e2555b5275054c SHA512 96419d6d35801117584fd217d269bbce81e50523cadef397417f5218648de544bbb2f11eed4be1d55f5a3e456f15724ef3b2f0b0f26764471089be5d2bed7d7d
diff --git a/app-text/iso-codes/iso-codes-4.17.0.ebuild b/app-text/iso-codes/iso-codes-4.17.0.ebuild
new file mode 100644
index 000000000000..1b5f1e4ee079
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.17.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mr ms mt my na nah nb_NO ne nl nn nso nv oc or pa pa_PK pap pi pl ps pt pt_BR ro ro_MD ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hans zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( CHANGELOG.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}