summaryrefslogtreecommitdiff
path: root/app-text/info2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /app-text/info2html
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'app-text/info2html')
-rw-r--r--app-text/info2html/Manifest1
-rw-r--r--app-text/info2html/info2html-2.0-r1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-text/info2html/Manifest b/app-text/info2html/Manifest
index bc2b233e21ea..88296708eaf5 100644
--- a/app-text/info2html/Manifest
+++ b/app-text/info2html/Manifest
@@ -1,4 +1,5 @@
AUX info2html-2.0-xss.patch 2206 BLAKE2B 12daf13818b6c6a32932185f543bdfdfbb318d91f80ede4fe2495f9fe5d0dfc3183ad10b8e66d529530ea853834be2f029d94a81e7eebde5e8cfa67c06508797 SHA512 9ffdd82d6cd0f53473fa8eedd5372c09b3a0a2f2b59bea229320fb77bf07d9f9a9f6892585250cd9fa5034213b2b08a346e739ae931c6a42bbdc73487348b947
DIST info2html-2.0.tar 51200 BLAKE2B 0209e7792689f68c8f596dcb0771395014963240f2071aa970f50611f752e9b9cf524ba2083a72a9b0f4346f8e14e23aedfde4497b05c02dae90b223ebcf6311 SHA512 1b9ebc8bdd4101d24116fe22df9e5d3124300b2ac11585d8c7fff9652f7984983480442af9d9f86300f9684335d85b96f276a775c56c95e7fac85ebc46235e06
+EBUILD info2html-2.0-r1.ebuild 1914 BLAKE2B 861c434b51a57e9a7641e2150e87c10a760ed0c13303ef1f2e7044e021923d23a9c870c1f4d2b7ec947b859736462ec775130eca325d9c07cec4b019f263549e SHA512 d6895e403e119a66884628d495fdc3345c6d0f9696468fccaabc8f339fa57a739baae1f3474efe58dc572a7a5dab881e33f7e3d45c77e682bd774bb6f0efd7db
EBUILD info2html-2.0.ebuild 1936 BLAKE2B 35ad17ff213a187eb6a9b91e85c4e6e4c4cc9428cabf004d071aa0af4a9f6517dcaa06b76860523552250a0cb682982d587764b00238d47de080f63d14fb92e3 SHA512 e6064454cea807c4bd187f00796231ca53dbf1290aa7bca05eb56a048e0cce9c86b9ca857d5e18ad4e1ab036029acddbd74ba7aaf0592d8b5da58d1cf5f8b700
MISC metadata.xml 329 BLAKE2B 9d0be1049ee8b84a11cf0b216e1e05263409f28ec1169978454df89f9726bdcdf1b63ba824f534606bdcd2163dd7b8e1aa9bf9497dfcb6410c0eb3b63958311a SHA512 18e0083cb85393d3d92abda8016dcdebe9f84fcd176557cb433b858ed9b6087ce7e5b53022d689e3861526d10440a9fe7fd6a1d86782a76d8f0756c3046bae23
diff --git a/app-text/info2html/info2html-2.0-r1.ebuild b/app-text/info2html/info2html-2.0-r1.ebuild
new file mode 100644
index 000000000000..3bacec7b49a4
--- /dev/null
+++ b/app-text/info2html/info2html-2.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils webapp
+
+DESCRIPTION="Converts GNU .info files to HTML"
+HOMEPAGE="http://info2html.sourceforge.net/"
+SRC_URI="mirror://sourceforge/info2html/${P}.tar"
+
+LICENSE="freedist"
+# webapp.eclass deals with SLOTting
+#SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~hppa ~sparc ~x86"
+
+RDEPEND="dev-lang/perl"
+PATCHES=(
+ # filter user-provided data to prevent cross-frame/site scripting attacks
+ # bug #91354 (fix from Werner Fink)
+ "${FILESDIR}"/info2html-2.0-xss.patch
+)
+
+src_prepare() {
+ default
+
+ # Fixup INFODIR for paths in /etc/profile.env INFOPATH
+ infos=$(grep "^export INFOPATH=" /etc/profile.env | tail -n 1 |\
+ sed -e "s:^export INFOPATH=:INFOPATH=:;s:'::g")
+ # Default path to /usr/share/info and /usr/local/share/info
+ [[ -z ${infos} ]] && export infos="/usr/share/info"
+ infos=( ${INFOPATH//:/ } )
+ mv "${S}"/info2html.conf "${S}"/info2html.conf.orig
+ touch "${S}"/info2html.conf
+ state="copy"
+ inserted="no"
+ while read line; do
+ [[ ${line} == "@INFODIR = (" ]] && state="insert"
+ [[ ${line} == ");" ]] && state="copy"
+ case ${state} in
+ "copy")
+ echo ${line} >> ${S}/info2html.conf
+ ;;
+ "insert")
+ echo ${line} >> ${S}/info2html.conf
+ for info in "${infos[@]}"; do
+ echo " '${info}'," >> ${S}/info2html.conf
+ done
+ echo " '/usr/local/share/info'" >> ${S}/info2html.conf
+ state="skip"
+ inserted="yes"
+ ;;
+ "skip")
+ ;;
+ esac
+ done < "${S}"/info2html.conf.orig
+ [[ ${state} == "copy" && ${inserted} == "yes" ]] ||
+ die "Setting up info2html.conf failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ exeinto ${MY_CGIBINDIR}
+ cp info2html infocat info2html.css info2html.conf "${D}"/${MY_CGIBINDIR}
+ # README zapped by info2html-gentoo.patch; it only listed
+ # the homepage so it doesn't add anything useful.
+ # dodoc README
+
+ webapp_src_install
+}