summaryrefslogtreecommitdiff
path: root/app-text/hyperestraier/files/hyperestraier-perl.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/hyperestraier/files/hyperestraier-perl.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/hyperestraier/files/hyperestraier-perl.patch')
-rw-r--r--app-text/hyperestraier/files/hyperestraier-perl.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-text/hyperestraier/files/hyperestraier-perl.patch b/app-text/hyperestraier/files/hyperestraier-perl.patch
new file mode 100644
index 000000000000..dbafd483d926
--- /dev/null
+++ b/app-text/hyperestraier/files/hyperestraier-perl.patch
@@ -0,0 +1,24 @@
+--- a/perlnative/Makefile.in
++++ b/perlnative/Makefile.in
+@@ -29,10 +29,10 @@
+ # Building binaries
+ PERL = @PERL@
+ POD2HTML = @POD2HTML@
+-CC = gcc
++CC = @CC@
+ INC = -I. -I../.. -I$(MYHEADDIR) -I$(HOME)/include -I/usr/local/include
+ OPTIMIZE = @MYOPTIMIZE@
+-LD = gcc
++LD = @CC@
+ LIBS = -L../.. -L$(MYLIBDIR) -L$(HOME)/lib -L/usr/local/lib @LIBS@
+ RUNENV = LD_LIBRARY_PATH=.:..:/lib:/usr/lib:$(MYLIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
+
+@@ -46,7 +46,7 @@
+ all :
+ ( cd src && if ! [ -f Makefile ] ; \
+ then $(RUNENV) $(PERL) Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
+- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; fi )
++ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS="vendor" ; fi )
+ ( cd src && make )
+ @printf '\n'
+ @printf '#================================================================\n'