summaryrefslogtreecommitdiff
path: root/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild')
-rw-r--r--app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild b/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..4b9258115b94
--- /dev/null
+++ b/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Recodes HTML file using a new character set"
+HOMEPAGE="https://bisqwit.iki.fi/source/htmlrecode.html"
+SRC_URI="https://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-ar.patch" )
+
+src_prepare() {
+ touch .depend argh/.depend || die
+ default
+}
+
+src_configure() { :; }
+
+src_compile() {
+ local makeopts=(
+ AR="$(tc-getAR)"
+ CPPDEBUG=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+ emake "${makeopts[@]}" -C argh libargh.a
+ emake "${makeopts[@]}" htmlrecode
+}
+
+src_install() {
+ dobin htmlrecode
+ dodoc README.html
+}