summaryrefslogtreecommitdiff
path: root/app-text/htmlmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-text/htmlmin
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-text/htmlmin')
-rw-r--r--app-text/htmlmin/Manifest4
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12.ebuild18
2 files changed, 13 insertions, 9 deletions
diff --git a/app-text/htmlmin/Manifest b/app-text/htmlmin/Manifest
index 224a83783247..08d0ba1cc046 100644
--- a/app-text/htmlmin/Manifest
+++ b/app-text/htmlmin/Manifest
@@ -1,3 +1,3 @@
-DIST htmlmin-0.1.12.tar.gz 19940 BLAKE2B 66e9596f687b70fa44362078075cb5f70553e65a7a1a6c55a4abac6adc5d0821b8936507cbb56f4e8ea96575a8801ec341416fead54b18ff9e10d199ed506529 SHA512 5669327dc64d8d28accdfe0d9a222e723fccdc12b52e7f0315fb9caf958a734a0cf0514ad476cbd0b7d0f2d83514a207867127f135f5e51cfda9b15dbfe24b78
-EBUILD htmlmin-0.1.12.ebuild 502 BLAKE2B 153cbfaaf0ad87a086a7a3d699eaa8db44d492af5f3b54e3933e59f097cdf26f6c76e5ea502455606a1a53185951f70cebb9fa4522abb65713f03910c46e7d99 SHA512 d03810cfb4d4d71bbd69c89edaecd72a9b8a9e546e9f8a9f172c9c52d7441aa90824317729fc2b9ce959642de525570d7fb5623b854560469e11208994a89bd6
+DIST htmlmin-0.1.12.gh.tar.gz 134130 BLAKE2B 5a9996bfea469f273c37bd0bd72c0e27b8636cb4552681de1b7e9a4849ab215815f7fc8ce430392b8ca3a849b3e51d8188ca248a8ce23242905799258ceeae29 SHA512 6d9db4b6bcdd6d223be8b4e3830da4d63ac6d7d28ee83abd97809b0b901968c994c8434c992fbdd148101ba25d8d786c93657cb5f82881af44dadbba40bf3252
+EBUILD htmlmin-0.1.12.ebuild 687 BLAKE2B e16da15d3ca3b741f324db20f52f09cc6a57471863068908c54635fa26ec84f99fd30043f03dcd14d11072a5c06734c86263461da77b8ac8de486ea54daf4953 SHA512 df59d6c9f9eb20b9db4eb4b4547c68607964f9abd9b5be4fbb0fc85cf5afe446241237031234c6c30f608ed2d56471eb024072ff83a793ceae94c0ec62e68c13
MISC metadata.xml 424 BLAKE2B 1026b0d3b470845caf9f575527f76c10b691c855426e5fe48972943ca067e9c4211f3e5af025b85f3881c321614c174f6c2f751c2f3f0764aedf04abb2dfe125 SHA512 53ae65ab7e6dd530f398c228e7ad38242a367efdd398a5bd321704e42f33b997c4fc5bfb942a90722b164ff29b35c1f6e3d3e15414241995bd371c3090c250e0
diff --git a/app-text/htmlmin/htmlmin-0.1.12.ebuild b/app-text/htmlmin/htmlmin-0.1.12.ebuild
index fc8e480e3b33..080c078b2222 100644
--- a/app-text/htmlmin/htmlmin-0.1.12.ebuild
+++ b/app-text/htmlmin/htmlmin-0.1.12.ebuild
@@ -1,25 +1,29 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
+# upstream doesn't do tags much
+EGIT_COMMIT=220b1d16442eb4b6fafed338ee3b61f698a01e63
DESCRIPTION="A configurable HTML Minifier with safety features"
HOMEPAGE="https://github.com/mankyd/htmlmin"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/mankyd/htmlmin/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
LICENSE="BSD"
-
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+distutils_enable_tests setup.py
src_prepare() {
sed '/prune/d' -i MANIFEST.in || die
- default
+ distutils-r1_src_prepare
}