summaryrefslogtreecommitdiff
path: root/app-text/htmlmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/htmlmin
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/htmlmin')
-rw-r--r--app-text/htmlmin/Manifest1
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12-r1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-text/htmlmin/Manifest b/app-text/htmlmin/Manifest
index 243f0bed6f69..653d3e4345ea 100644
--- a/app-text/htmlmin/Manifest
+++ b/app-text/htmlmin/Manifest
@@ -1,3 +1,4 @@
DIST htmlmin-0.1.12.gh.tar.gz 134130 BLAKE2B 5a9996bfea469f273c37bd0bd72c0e27b8636cb4552681de1b7e9a4849ab215815f7fc8ce430392b8ca3a849b3e51d8188ca248a8ce23242905799258ceeae29 SHA512 6d9db4b6bcdd6d223be8b4e3830da4d63ac6d7d28ee83abd97809b0b901968c994c8434c992fbdd148101ba25d8d786c93657cb5f82881af44dadbba40bf3252
+EBUILD htmlmin-0.1.12-r1.ebuild 697 BLAKE2B ec9fdecf1dabde5d6fccac4d95ec01419354e0ca538404c0f83990217c6c50e65da443c609a8a6a66841f57a80045423b88127016e5f1032e6f71193ba200dc7 SHA512 605b3e5e16824192f3519455a65bf511fd4d32117829cbc45b0263a94aefa49697ec91c43bc727d4c08c73b1d4d4f039b47d4378bfd22da42871ba785b750812
EBUILD htmlmin-0.1.12.ebuild 662 BLAKE2B 070d2784ba9c9ceb54247eb52d26ad5e23f37434dbf74e1fa33b97199de6bf3523b46190f170172b4b1367e1dc3b63204623f8b0a9ff2a5297b9e879e3a58f04 SHA512 1e976ee7e37c5f9f2607e9ec61e4b53e721020753dc8b0aed2594c146b9086401af4feeee7277b2d0f6cf7fe2e687e5530d6d97884517c15ed40c5c7e43ea096
MISC metadata.xml 503 BLAKE2B 120b7dfe5ecbbdf5b28ac559893d991071c39a34644aa6556abbf8c58c91f908003240f647ccbf58d6e1e776130e72a95bae033a07272ad213673960217acd9e SHA512 dbd48a6b9caca3a7c2e4789653c133321a6e42da5cde9b552c527d5afde0e0c7c0ee25a4712822a4bc1768424c0e3d7216f6d56a24899f2f0aed0b6a20bee61e
diff --git a/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild b/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..6bc38c00903f
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+# upstream doesn't do tags much
+EGIT_COMMIT=220b1d16442eb4b6fafed338ee3b61f698a01e63
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="
+ https://github.com/mankyd/htmlmin/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in || die
+ distutils-r1_src_prepare
+}