summaryrefslogtreecommitdiff
path: root/app-text/htmlmin/htmlmin-0.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
commit618c3037024b4e5328531cdc07c6ceb7486f5329 (patch)
tree7c9f8d50c6f5fbd53f3df583c471f5d2e5c34202 /app-text/htmlmin/htmlmin-0.1.12.ebuild
parent76dfef0cec9170000357d2f354e412daf48941fc (diff)
gentoo resync : 31.12.2017 (final resync this year)
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.12.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.12.ebuild b/app-text/htmlmin/htmlmin-0.1.12.ebuild
new file mode 100644
index 000000000000..3f036caef84b
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in
+ default
+}