summaryrefslogtreecommitdiff
path: root/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild b/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
new file mode 100644
index 000000000000..89d79280a31f
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+HTMLMIN_GIT_REVISION="7bcbb995778fc07e427872dc74af9646fd0c907d"
+
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="https://github.com/mankyd/${PN}/archive/${HTMLMIN_GIT_REVISION}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in
+ default
+}