summaryrefslogtreecommitdiff
path: root/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild')
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
new file mode 100644
index 000000000000..3a6d05570bbb
--- /dev/null
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="HTML Include System by Ulli Meybohm"
+HOMEPAGE="http://www.meybohm.de/"
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/htmlinc
+
+src_prepare() {
+ epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ # This is C++ not C source
+ emake \
+ CC=$(tc-getCXX) \
+ CFLAGS="${CXXFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin htmlinc
+ dodoc README
+}