summaryrefslogtreecommitdiff
path: root/app-text/htmldoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htmldoc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htmldoc')
-rw-r--r--app-text/htmldoc/Manifest3
-rw-r--r--app-text/htmldoc/htmldoc-1.8.30.ebuild43
-rw-r--r--app-text/htmldoc/metadata.xml5
3 files changed, 51 insertions, 0 deletions
diff --git a/app-text/htmldoc/Manifest b/app-text/htmldoc/Manifest
new file mode 100644
index 000000000000..6579633cfb00
--- /dev/null
+++ b/app-text/htmldoc/Manifest
@@ -0,0 +1,3 @@
+DIST htmldoc-1.8.30-source.tar.gz 3901592 BLAKE2B 1aad75973ce485fdbe15d6db99701f88a0fd48a075014c401cc8fdb1f9031214a148748e6731542ca8df7bfa5e5f4c50ec772dac4231fdd71e70f6b092bd20ac SHA512 713dc67622533dae896745ac8809e43a7f91696715aeb77df2628bd04c0d3e16c8402891499e8e0c10cab793b44114e600d5935b3c76a3cfa303c10897456804
+EBUILD htmldoc-1.8.30.ebuild 1113 BLAKE2B e4749513e062adf119f68acfa3ff0864ee035643791ded81316032196366fa74bb60a5b56ffe57b48481d458e973e7b406aa11f0b27d3dfa306b721d25991ef4 SHA512 535e27ae7e6ac09315b0f3b0290b0963320e0335ed91fd82cac323dcf431a99a2146f97a2cbbdf187dbd5401b8833594a84d912ae9ff832534848bcb7d35c94f
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/htmldoc/htmldoc-1.8.30.ebuild b/app-text/htmldoc/htmldoc-1.8.30.ebuild
new file mode 100644
index 000000000000..9fd2fd29c494
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.8.30.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+HOMEPAGE="http://www.msweet.org/projects.php?Z1"
+SRC_URI="https://github.com/michaelrsweet/${PN}/releases/download/v${PV}/${P}-source.tar.gz"
+IUSE="fltk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ppc ppc64 sparc x86"
+
+DEPEND=">=media-libs/libpng-1.4:0=
+ virtual/jpeg:0
+ fltk? ( x11-libs/fltk:1 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # make sure not to use the libs htmldoc ships with
+ rm -r jpeg png zlib || die 'failed to unbundle jpeg, png, and zlib'
+
+ # Fix the documentation path in a few places. Some Makefiles aren't
+ # autotoolized =(
+ for file in configure doc/Makefile doc/htmldoc.man; do
+ sed -i "${file}" \
+ -e "s:/doc/htmldoc:/doc/${PF}/html:g" \
+ || die "failed to fix documentation path in ${file}"
+ done
+}
+
+src_configure() {
+ CC=$(tc-getCC) CXX=$(tc-getCXX) DSTROOT="${D}" econf $(use_with fltk gui)
+}
+
+src_install() {
+ emake DSTROOT="${D}" install
+}
diff --git a/app-text/htmldoc/metadata.xml b/app-text/htmldoc/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/htmldoc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>