summaryrefslogtreecommitdiff
path: root/app-text/htmldoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 18:55:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 18:55:17 +0000
commit1e3939094253168dfdada63e645d674cad69260e (patch)
treeac694a92b15d94d2e7544b8591123b7b04cf11e9 /app-text/htmldoc
parentc98eb096c37a4252dc388920f0b0f8b2441c9b5d (diff)
gentoo auto-resync : 16:11:2022 - 18:55:17
Diffstat (limited to 'app-text/htmldoc')
-rw-r--r--app-text/htmldoc/Manifest2
-rw-r--r--app-text/htmldoc/htmldoc-1.9.16.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/htmldoc/Manifest b/app-text/htmldoc/Manifest
index a5a61423ebeb..261138f2ca59 100644
--- a/app-text/htmldoc/Manifest
+++ b/app-text/htmldoc/Manifest
@@ -1,3 +1,5 @@
DIST htmldoc-1.9.11-source.tar.gz 4471815 BLAKE2B a76da0f5129d8d637c440ee1880bdc4c314db02294f8e7387abe28ab7f76a81b47c4670a27d34759f89b82e9b1d7c259d154fac7cb8c2b7caa6e1f99f3a35ebf SHA512 5ee6a61f129be9a7d26c554f1acb533f1edfbf34eefd8f4924e07bcead2680407c68b4e2c9840203d7bb07daf51ea18c422d7c04e33c4b346dd207531f330678
+DIST htmldoc-1.9.16-source.tar.gz 3389563 BLAKE2B 1c83e37313fb0a1196d4db3ddca47d4a418ab7aeb8f910c9a27178312a1b0239beddaf81f322b24dcf75dff7e838278fcfa0eed17b5aa493790de2393bcddebf SHA512 c901ed259ef8c0520ed03e314149e7a2fc3b5bffa9c8e9c6c3b023a8c9de1e37b7fa72d224fa7d072f3a5d4b379635d7cfaa016df672da296be8395b49fa935b
EBUILD htmldoc-1.9.11-r1.ebuild 1360 BLAKE2B f63c196fd6df2bc869e266d2d356c5ca1a56b45a7d1e07e479855e13a915a8fdc82ec7ad1b5270250823c7b4364a24020c507e4a27511dd3debf67a29f2f1f43 SHA512 cfd9f740c0c973bd933b1c0235b3271e84e8c4b6923e1ecf9a509dbff78472ad4d5bb09d9a6f9ced6eda952f08258e400f52a2aa01b9bcbf6b6ecccdb484334c
+EBUILD htmldoc-1.9.16.ebuild 1192 BLAKE2B 7b466e0aa764a8be762462a26209fecfff233ecb25f99202b6d129358d13a2dcad8957e22c77c66ba9f14372f54d1702ee35d09b0f1018b7a38361fd0b08c70d SHA512 62ab25c91855d3fa1b0717bd932700d00afd3193216e461520dae227cff428c04b293d8da1c8c4f66bf94dc54a314c5f216131d9fb70a163e250f27aa6ba77ad
MISC metadata.xml 254 BLAKE2B 149f11a69823369fb86bd87780bac2b15b2b4da48b793ba085a35280b415a731a4d6f722e5dbf8171a53fda094f16d12445d38b281293f076e171e9e5c36b474 SHA512 cad3377b826d8335228b5b299ffe2ff461d90f6b0693cd0af475ec7f37fa75b437a6ad13d244294d8f0c14f3e93ae7bb0762408f6d9ff3655476d558d0af1c8f
diff --git a/app-text/htmldoc/htmldoc-1.9.16.ebuild b/app-text/htmldoc/htmldoc-1.9.16.ebuild
new file mode 100644
index 000000000000..01ef5f97775f
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.9.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs xdg
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+HOMEPAGE="https://www.msweet.org/htmldoc/"
+SRC_URI="https://github.com/michaelrsweet/${PN}/releases/download/v${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="fltk ssl"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libpng-1.4:0=
+ sys-libs/zlib
+ ssl? ( net-libs/gnutls:= )
+ fltk? ( x11-libs/fltk:1 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Fix the documentation path in a few places. Some Makefiles aren't
+ # autotoolized =(
+ for file in configure doc/Makefile doc/htmldoc.man; do
+ sed -i "${file}" \
+ -e "s:/doc/htmldoc:/doc/${PF}/html:g" \
+ || die "failed to fix documentation path in ${file}"
+ done
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with fltk gui)
+ $(use_enable ssl)
+ $(use_enable ssl gnutls)
+ )
+
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIPPROG="true" DSTROOT="${ED}" install
+}