summaryrefslogtreecommitdiff
path: root/app-text/html2text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /app-text/html2text
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'app-text/html2text')
-rw-r--r--app-text/html2text/Manifest1
-rw-r--r--app-text/html2text/html2text-2.2.3-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-text/html2text/Manifest b/app-text/html2text/Manifest
index 20a2fe59c5c7..8b1f85145263 100644
--- a/app-text/html2text/Manifest
+++ b/app-text/html2text/Manifest
@@ -1,5 +1,6 @@
DIST html2text-2.1.1.tar.gz 172655 BLAKE2B ab112e41b9cb08664ae9cba2b137b59e67769b2c8cd758022e9b650a2cbd1788064ada1949e9efddc591c819b0c86890e22504bebde68c2973c353b6fa85da33 SHA512 e7fbd795b06895d866e3379c343860dc8816d5069b476cd13abeb066ba1ad222050863c1d52c6b2c05d426a17af7b427913341c8205964b21f18a3d26c3528c4
DIST html2text-2.2.3.tar.gz 329841 BLAKE2B 311defd6aa6affc6f1ad59d9971f0315b6f2d748b4ae26e2c5f61cbd090ff76f0f0df7155acb1ec5c0114a6b6253eb27fc73d327162dca2a144afae74cdf4afa SHA512 ff851abdc0f672d6bf8de494d6595362d5b71eeb03f4f761e32afb50bb75fe12c0cede8c7ca4ca7290b1c9e0f08aaff9821946dd272e1a30ce3b585e452cf6ec
EBUILD html2text-2.1.1.ebuild 889 BLAKE2B 2cfb411255c612699631c5e25d62055f8cd67bf0d69ec3b17380d173311338ff8b07edc894d65ac23998d89041c0f91d550206839b42574b7ea709a0f6dd8732 SHA512 b3859f9758680fd85934b17e3fdccd45589ab5bcc574dd4cbfa327269bd92d6ec173b02d61908b579c4273fd98561e98a2f054adb28329f05c83c1cc0d98489a
+EBUILD html2text-2.2.3-r1.ebuild 642 BLAKE2B 30fe78de8b9acc82d392c28ee9340cd813a7596f79c1ac90448c5faea1eec6f32560857eb36b876651497033601fe7953c0818bc4c094a93ecebd24424a2ca94 SHA512 2bbd4f0fbfd490bea42de9a7e51a5d8fca5865f3036c5b1a6646c2cc55c4103de565af6b5d5964117ef61bb36ff70818b256893b9af7b6f1d19728e07d4d6de7
EBUILD html2text-2.2.3.ebuild 667 BLAKE2B a2042fcfc0d95631896629db64f44eeccef1375c372551d95d0ad0ebdf77adc29ef628b7f12b483a1165ee57bac6c70757cce110d107ed9b0d25b8415b7fda2e SHA512 077bad82be394f4302dcdd2ad04ac2d2106f187817f03fc3f0d52e804836742883855a5843a468010c82470826fb608ed7cd5e87922427b3d02bb65ff4dc9f58
MISC metadata.xml 331 BLAKE2B 43e61ec021521aaae0dcdbbcef0a40be6da311dd188cf64c66a8dc5c4191befa9955c669cec80d1d9dd0ed584f35e8f3076a0a1d9986e9453c3d96a0cc3ae921 SHA512 dd843839ec2124a68865214d5d2b71d5af631c26bf86fd37f48af940ccd9aa5f1543c9e6232b44119edd7ca429ea869df2acdbf9faafd1454936e23a52d721cf
diff --git a/app-text/html2text/html2text-2.2.3-r1.ebuild b/app-text/html2text/html2text-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..9bd222dc8965
--- /dev/null
+++ b/app-text/html2text/html2text-2.2.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/grobian/html2text.git"
+else
+ SRC_URI="https://github.com/grobian/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="https://github.com/grobian/html2text"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ emake check
+}