summaryrefslogtreecommitdiff
path: root/app-text/html2text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-text/html2text
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-text/html2text')
-rw-r--r--app-text/html2text/Manifest1
-rw-r--r--app-text/html2text/html2text-1.3.2a-r2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/html2text/Manifest b/app-text/html2text/Manifest
index 929605561a04..07cbe125d07c 100644
--- a/app-text/html2text/Manifest
+++ b/app-text/html2text/Manifest
@@ -4,5 +4,6 @@ DIST html2text-1.3.2a.tar.gz 130088 BLAKE2B 97ca951ae7c501cefca78378683de7fb3c32
DIST patch-amd64-html2text-1.3.2a.diff 2230 BLAKE2B 332adeeceed512a2c5bfc01985efbaa4db5ea64b3e4ef8be8b880754524771de2e11b3a2efc55bce154bedc9e598231a1b5bcfe10e915b833d6dbcbcd9e46dc9 SHA512 2a421a20aec8a547bbdf54b81e30a6a1d4cf093e7ad67b27158f0c7248ca0abadd8d96ce0a27adcdd375012db6fd21f61f42a8343bfd910cd8a9720c0a043be1
DIST patch-utf8-html2text-1.3.2a.diff 29499 BLAKE2B ffc0ea8d89d9e9c9dfa89c2369016685a6af1403a6e71787df2724b72c74c8f774d8d92278a1aaeb90f47d34c8de4c889a7bf4edc02a00e3c97955ea624cfa71 SHA512 be31251471b221a38d291420d5f23e01d5017c20d953064c33ca3dd148543ae877ab584c16fcb01df1341abdb02494b05d08fdcf94bf70bad6b510ee8fac3376
EBUILD html2text-1.3.2a-r1.ebuild 994 BLAKE2B a6ecf556040564c64bba93dc0dd4d9fcf5060df5a6b9a487ea91f4b2b1fac6da4f4783910a86a98cc2e2c02c9f2ee19bc7ab9f7e40d0441f56c07f28b2979a45 SHA512 94ad8a3df67dc20c080bab7a5eabe3ed2f38c39df6f454f6425b0033774b5aa0f393afe16d69e01f499ee69c2f31316a979cc0326e19737550d5bfa57603e0fb
+EBUILD html2text-1.3.2a-r2.ebuild 974 BLAKE2B 2e2c23b127324b054e57c6d4927c43b39baf04fa977329f5b5a9f168f242d5ced6e2db251b6429d1aa4c020dcb29d6d0730606b21c711ab9909cd633d3f5aee3 SHA512 723302d8745c83cf48c1dc8406d4b6bf575b975164b3123ac2b40d5e882ccf7449709229975dc4bac23da0860ef86283749f4ac89be5ef68e30f5d344fbe12b5
EBUILD html2text-1.3.2a.ebuild 933 BLAKE2B 79617efc95c443681009563030126da8aadc589ae081b7162a700622367647112fae06271797923f0de4ed462aa4b89d17f2ab36084dae3edfbf67784cdb0797 SHA512 ab234c98f3998db61cb17dad4fc72dbfa184a93511d7a4482bee1dd0f1a350ef59645b5ffbd427fb0d4107135d19a95cb3cf8e36760377309e63076a56158e4a
MISC metadata.xml 373 BLAKE2B a4ea5de91e4a5f5a7653f4c9d86262c999e72c69863f0185700bd4fab6c27cf87d3e392aa013dd4b60a84b1ea0ddc42d811c4131c8db3ba427df86df7fa4abb8 SHA512 ae24dd6abb85c0abb4085f15c9c140d2dc3bb0c201ee22f1762e1eadc37899e8b5aa5cb794f9cd12bc26857195c9b9ba8cfa46d05628cdf765ddfc0639dd6bd4
diff --git a/app-text/html2text/html2text-1.3.2a-r2.ebuild b/app-text/html2text/html2text-1.3.2a-r2.ebuild
new file mode 100644
index 000000000000..f96c4819e230
--- /dev/null
+++ b/app-text/html2text/html2text-1.3.2a-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="http://www.mbayer.de/html2text/"
+SRC_URI="http://www.mbayer.de/html2text/downloads/${P}.tar.gz
+ http://www.mbayer.de/html2text/downloads/patch-utf8-${P}.diff
+ http://www.mbayer.de/html2text/downloads/patch-amd64-${P}.diff
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+PATCHES=(
+ "${FILESDIR}/${P}-compiler.patch"
+ "${FILESDIR}/${P}-urlistream-get.patch"
+ "${DISTDIR}/patch-utf8-${P}.diff"
+ "${DISTDIR}/patch-amd64-${P}.diff"
+)
+
+src_prepare() {
+ default
+ gunzip html2text.1.gz html2textrc.5.gz || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" DEBUG="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin html2text
+ doman html2text.1 html2textrc.5
+ dodoc CHANGES CREDITS KNOWN_BUGS README TODO
+}