summaryrefslogtreecommitdiff
path: root/app-text/html-xml-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-text/html-xml-utils
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-text/html-xml-utils')
-rw-r--r--app-text/html-xml-utils/Manifest2
-rw-r--r--app-text/html-xml-utils/html-xml-utils-8.5.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/Manifest b/app-text/html-xml-utils/Manifest
index 9ec7c8716dfe..77030c1dac4a 100644
--- a/app-text/html-xml-utils/Manifest
+++ b/app-text/html-xml-utils/Manifest
@@ -1,3 +1,5 @@
DIST html-xml-utils-7.8.tar.gz 408201 BLAKE2B c2fed68e8fa0ae331ff6ce100afdd4c7c5b272b47d806c8e557855d32d2a140c2aa580d200644158350697e62c416d16a5e264c09897cef06d29cc5f0ab67091 SHA512 8d3a242203de099b36ca78a8d84571ecc5d8673855ee613f98edc48d388230367f40b87006f7b429e2927026300626bed7ff7f146df317d078e332091d290930
+DIST html-xml-utils-8.5.tar.gz 421376 BLAKE2B 8fa959104db2d5765ceaf49be815f16c1422a3c7b94e0e8cd91e3bd0a8b18dfc33dff5d98204d7fe5694cfb711d213a5d82f58159b6d493fc78336d8dae1824d SHA512 f1140a81e66cc2f46dd0507a8948b2c267230fa8aed3dc79e91eeb2b6bcfe7053378da9d35fd053f8a8bc25c46491388aa7fd519c7e1c7757e73a7e1b1c67d87
EBUILD html-xml-utils-7.8-r1.ebuild 636 BLAKE2B c1a01d75323ce5616297934672afc2a985778962179d92de972ee1f7d5d1644c200d347585c127d27937602fc1e95dc669b8238646f62584506dff955c8f7faf SHA512 a7f8458a34485135c1e90110a66cd7b825e8c7e54961ce28606a86a3e91cff4cc87635207c80f4f1c5e05bd5bc11ec9bab7c66f9bdef9193dd6107ca975ec1e1
+EBUILD html-xml-utils-8.5.ebuild 640 BLAKE2B e305829e9622960920ac0fe06487b561eb4d05eb56f939abc1c5d32e3ccd5229ad6b05a869c9731f72ae36667d74190ce404b139900508ecd609599dfa65549a SHA512 43fb1cb0ba3d981676559ced03cb28ee9a72c91aed5a3d84fd2171fdbddc5a6abf32601386e6aee9fe9e2eb942365a9be44b6d44791631c144bc296b6c6c8005
MISC metadata.xml 221 BLAKE2B b43b26fbdad8e1ac12cf97bc9bfbf06f5633feefed4f3e7c9623dcf4c45b97a3b753f8c8787d267f6cf6412878f4f5893a5201279401571ca7e53bc255296324 SHA512 5b5336bc7e4015c10967f6a0f8525f2235a438789cfbaa08b8261eea6fa2019191de60e3ec310660e0e5eb931835004b9db604dd18278822cf9d0254469a0bad
diff --git a/app-text/html-xml-utils/html-xml-utils-8.5.ebuild b/app-text/html-xml-utils/html-xml-utils-8.5.ebuild
new file mode 100644
index 000000000000..bf51929c322d
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-8.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
+HOMEPAGE="https://www.w3.org/Tools/HTML-XML-utils/"
+SRC_URI="https://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ net-dns/libidn2:=
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/doc_DATA = COPYING/d" -i Makefile.in || die
+}
+
+src_test() {
+ # Lots of tests lack a shebang and use bashisms
+ emake check SHELL="${BROOT}"/bin/bash
+}