summaryrefslogtreecommitdiff
path: root/app-text/hd2u
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/hd2u
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/hd2u')
-rw-r--r--app-text/hd2u/Manifest4
-rw-r--r--app-text/hd2u/files/hd2u-1.0.3-build.patch25
-rw-r--r--app-text/hd2u/hd2u-1.0.3.ebuild24
-rw-r--r--app-text/hd2u/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/app-text/hd2u/Manifest b/app-text/hd2u/Manifest
new file mode 100644
index 000000000000..f3e0e5d43aff
--- /dev/null
+++ b/app-text/hd2u/Manifest
@@ -0,0 +1,4 @@
+AUX hd2u-1.0.3-build.patch 666 BLAKE2B 14d1e7cbb7c7302ec0aa1354c4d0a493645f8bf4bf9e4c2e2fa2bd61b04e0e7e8f90477deb6a73a1777ff2f12ad13cdd97f604d889778759d7fe21222772eff6 SHA512 934fe3043aceeeee5df7ae5879198d385639f5b489581209c44e7ec91f5d05216424bf5652f557e154a1a442633848ebe1167b61af9c9e374cd30594744f4d7d
+DIST hd2u-1.0.3.tgz 60024 BLAKE2B 9dd57f2e15add3643aa92747836164b18c9c6554c435b718cea6b4e8d1455bbd775f9d4eda0f10a9bfe3ccb5dbd634a99b367ae849bce2145d9b1114400a2b1b SHA512 d354964f0ad5392315767b96438d843a5f1d6afe78da5b0c5ea65a3b0b2a61beabff3ecac89df81b9271a14ca443f23dfffeb51815e02b724ad287e42fc2d6cc
+EBUILD hd2u-1.0.3.ebuild 515 BLAKE2B 4e84e7cdb9f6626cc61397559942ba15505de1ae819ce032c548581a1f271c8015d3feef8fd0840cbe63273df6debd80fa6acfa1a044707824649d19763b9814 SHA512 d0a7153a1d1961c2a1cf31028f300362a5fbaa6959719404c8f5d8cffd0bfdecc2cff47946aacd2a57fad53635532519ae8d09929acf86a654fdd041c32f03b7
+MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/app-text/hd2u/files/hd2u-1.0.3-build.patch b/app-text/hd2u/files/hd2u-1.0.3-build.patch
new file mode 100644
index 000000000000..de788e8aa774
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.3-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 2a67b3c..651323d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,7 +42,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+
+ all-optimized: $(TARGET)-optimized
+@@ -98,9 +98,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)
diff --git a/app-text/hd2u/hd2u-1.0.3.ebuild b/app-text/hd2u/hd2u-1.0.3.ebuild
new file mode 100644
index 000000000000..af0d97d7f58b
--- /dev/null
+++ b/app-text/hd2u/hd2u-1.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Dos2Unix like text file converter"
+HOMEPAGE="http://www.megaloman.com/~hany/software/hd2u/"
+SRC_URI="http://www.megaloman.com/~hany/_data/hd2u/${P}.tgz"
+
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="
+ dev-libs/popt"
+RDEPEND="${DEPEND}
+ !app-text/dos2unix"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
diff --git a/app-text/hd2u/metadata.xml b/app-text/hd2u/metadata.xml
new file mode 100644
index 000000000000..3cf14bf74636
--- /dev/null
+++ b/app-text/hd2u/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+</pkgmetadata>