summaryrefslogtreecommitdiff
path: root/app-text/gv/gv-3.7.3.90.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/gv/gv-3.7.3.90.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/gv/gv-3.7.3.90.ebuild')
-rw-r--r--app-text/gv/gv-3.7.3.90.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/gv/gv-3.7.3.90.ebuild b/app-text/gv/gv-3.7.3.90.ebuild
new file mode 100644
index 000000000000..db63c43154e6
--- /dev/null
+++ b/app-text/gv/gv-3.7.3.90.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Viewer for PostScript and PDF documents using Ghostscript"
+HOMEPAGE="https://www.gnu.org/software/gv/"
+# Change 'gnu-alpha' to 'gnu' for final release, like 3.7.4
+SRC_URI="mirror://gnu-alpha/gv/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="xinerama"
+
+RDEPEND="app-text/ghostscript-gpl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXaw3d-1.6-r1[unicode]
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ export ac_cv_lib_Xinerama_main=$(usex xinerama)
+ econf --enable-scrollbar-code
+}
+
+src_install() {
+ default
+ doicon "${FILESDIR}"/gv_icon.xpm
+ make_desktop_entry gv GhostView gv_icon 'Graphics;Viewer'
+}