summaryrefslogtreecommitdiff
path: root/app-text/groonga
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 11:36:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 11:36:37 +0100
commitd6fe3a53bdeea6b060d1755199cc2c27492dc14c (patch)
tree7bb8240ab620eafcfe59b3d1b45831bf45e12501 /app-text/groonga
parent4bbcd26e7cb1908fb98bb318bfaa13ea9e32d860 (diff)
gentoo auto-resync : 10:04:2023 - 11:36:36
Diffstat (limited to 'app-text/groonga')
-rw-r--r--app-text/groonga/Manifest2
-rw-r--r--app-text/groonga/groonga-13.0.1.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
index 6b588e80ca6b..1bccd2321a45 100644
--- a/app-text/groonga/Manifest
+++ b/app-text/groonga/Manifest
@@ -1,5 +1,7 @@
AUX groonga.confd 259 BLAKE2B 440b084d0e41da1b81e27ffa1e42963ce22d83027841039d488d516dce8beffce0e2ca03f5ca78a6aae02fa7bf238f0cf900e770ebfba04cfac581a13bd2381f SHA512 489feed6a4c22eb2ac02be070dd84ed3eb677b4f250b7eacd5619c1749b322b302bdff36fc3586e83125ac7ef02569054c4f267ddd7b26e5aa378af428cbc8ea
AUX groonga.initd 715 BLAKE2B 0cf870704257490477a7a254a670ef5ce48141b8c9c4119446bcfab92972319857c77ebe41044c7d338b10bb720744788ce0313f8b2ee50277571513d0cfdb83 SHA512 7b4f789c9201f40fee0d99b94554bc33aebf024da02794143317215713cea3f2a9fda2e87d2a8bb864a7d0c8a2c44e824c65deecd4c95360423f7d3a4f04f8c2
+DIST groonga-13.0.1.tar.gz 24694524 BLAKE2B 326ca810bdf4634b778eb6efc7a6c56626b0c5b563d9b896da23a103399e51ca57e8d1dd87aa05dbbe527f67cb6875924ca073f007698f5077437e2b191b995a SHA512 54eda0c70f932f249dbf58f01367d9a05a9d8e6e9a1df92e0a9070f452596cfc38da59b02c5128a585f9e19d460ce8100dd2677aaba7049e129a963491b22362
DIST groonga-8.0.2.tar.gz 15095427 BLAKE2B fa83034a434edaa35dede08cb042e48f15e1e2edd78a121f9341f53f53a5eef863d02e2ea6384428c720c4ff9acf1083504046c8c11a1ea8d7bfc4b541db66b5 SHA512 bc5590604054c4adfbc80b39c7cf367e8a989c47d80c37c48feffb9a427b4b4e360289f3d732f6affa7d26a1c8559f23bda1c70b6736a06601398fce9a53acf1
+EBUILD groonga-13.0.1.ebuild 2468 BLAKE2B 90851ef9b24af7858b4070bd189583ed28504dd913ea36e712d576bf2b271cab3481892937bd7341981b9c4d8200e4a79c93eddeaab8a451aef853bcbca0e8ab SHA512 20e4255bd0a9bf6d601fd3100fab16bec206cc21c49534470970b01933572824d26571938d8bd7403872a056a22dc3655a2179ba74ced7741942b4ddb478f06a
EBUILD groonga-8.0.2-r2.ebuild 2586 BLAKE2B 23477e51ccdaede52c9aa4635833b81cd855d25a8737f4ac9c8e206d3590ec2eeb7d3d36c248f270a4205d7ee30a1079aaf6ec99375525e9c1e2668ec6a5669d SHA512 edfc467ffb7c4b557f169b6cabca9e122c55ce822fcfd7d9609ac4b079b858f00f0a8a4212aca2627dd6cb11b65da2f17048606e8caee5f3480c734f38c2335e
MISC metadata.xml 1227 BLAKE2B 1dde649077d52213dba0445f8e1993768efc4a2cf6d9ef6b733ce38167dc2e65f0b43c540c3a22586737ebe4522e7f003d857057fd3edc3bff60da2418778e15 SHA512 86a65f7d5613baff642107e6ffc1ad484f9f4361cc07985d1945d256560e8994ba7d1f21b5555dce80d6a00dcba0ce06d4d174db93a5b50f35d959428e99bfdc
diff --git a/app-text/groonga/groonga-13.0.1.ebuild b/app-text/groonga/groonga-13.0.1.ebuild
new file mode 100644
index 000000000000..bef5cf610056
--- /dev/null
+++ b/app-text/groonga/groonga-13.0.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="https://groonga.org/"
+SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark debug doc +exact-alloc-count examples futex jemalloc libedit libevent lzo +mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib zstd"
+REQUIRED_USE="
+ sphinx? ( doc )
+"
+
+DEPEND="
+ >=dev-libs/onigmo-6.1.1:0=
+ dev-libs/rapidjson
+ dev-libs/xxhash
+ benchmark? ( >=dev-libs/glib-2.8 )
+ jemalloc? ( dev-libs/jemalloc:0= )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent:0= )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack:= )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq:0= )
+ zlib? ( sys-libs/zlib:0= )
+ zstd? ( app-arch/zstd:0= )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/groonga
+ acct-user/groonga
+"
+BDEPEND="
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )
+"
+
+src_prepare() {
+ default
+
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # Apache arrow, kytea and libstemmer are not available in Gentoo repo
+ # ruby is only used for an http test
+ local econfopts=(
+ --disable-groonga-httpd
+ --without-pcre
+ --without-kytea
+ --without-libstemmer
+ --disable-arrow
+ --with-log-path="${EPREFIX}"/var/log/${PN}.log
+ --without-luajit
+ --without-ruby
+ --with-shared-onigmo
+ --with-onigmo=system
+ --with-xxhash
+ $(use_enable benchmark)
+ $(use_enable debug memory-debug)
+ $(use_enable doc document)
+ $(use_enable exact-alloc-count)
+ $(use_enable futex)
+ $(use_with jemalloc)
+ $(use_enable libedit)
+ $(use_with libevent)
+ $(use_with lzo)
+ $(use_with mecab)
+ $(use_enable msgpack message-pack)
+ $(use_with msgpack message-pack "${ESYSROOT}/usr")
+ $(use_enable nfkc)
+ $(use_with sphinx sphinx-build)
+ $(use_enable static-libs static)
+ $(use_enable uyield)
+ $(use_enable zeromq)
+ $(use_with zlib)
+ $(use_with zstd)
+ )
+
+ econf "${econfopts[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ if ! use examples ; then
+ rm -r "${ED}/usr/share/${PN}" || die
+ fi
+}