summaryrefslogtreecommitdiff
path: root/app-text/grip/grip-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/grip/grip-4.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/grip/grip-4.2.0.ebuild')
-rw-r--r--app-text/grip/grip-4.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/grip/grip-4.2.0.ebuild b/app-text/grip/grip-4.2.0.ebuild
new file mode 100644
index 000000000000..32493d9a31af
--- /dev/null
+++ b/app-text/grip/grip-4.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy{,3} python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION='Preview GitHub Markdown files like Readme locally before committing them'
+HOMEPAGE='https://github.com/joeyespo/grip'
+LICENSE='MIT'
+
+SLOT='0'
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+KEYWORDS='~amd64'
+
+RDEPEND="
+ >=dev-python/docopt-0.6.2
+ >=dev-python/flask-0.10.1
+ >=dev-python/markdown-2.5.1
+ >=dev-python/path-and-address-1.0.0
+ >=dev-python/pygments-1.6
+ >=dev-python/requests-2.4.1
+"