summaryrefslogtreecommitdiff
path: root/app-text/gocr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-22 18:41:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-22 18:41:30 +0000
commit580f05ea8f512d11e23e8da80177d27835cbdbbc (patch)
tree48f1c956bdc671653181038c8d67d35bc8569d41 /app-text/gocr
parentf29eb0598f62fc3b5f09f2de5a89c0437c6164d9 (diff)
gentoo resync : 22.02.2020
Diffstat (limited to 'app-text/gocr')
-rw-r--r--app-text/gocr/Manifest2
-rw-r--r--app-text/gocr/gocr-0.50.ebuild34
2 files changed, 22 insertions, 14 deletions
diff --git a/app-text/gocr/Manifest b/app-text/gocr/Manifest
index 939ca357c8ce..71662c7d280f 100644
--- a/app-text/gocr/Manifest
+++ b/app-text/gocr/Manifest
@@ -1,3 +1,3 @@
DIST gocr-0.50.tar.gz 419209 BLAKE2B 232fe240d7a559cdd4408a3dba3768818aefbd8b2718c7ae40829d69ab79dd68293eb6adfc52e661f2f6cf1290ae9656c84d9d7a8fc20229c0942a8e18fb3b68 SHA512 36392516711d43f8561147684b6f4e22a450bc87f1cb30ceaab4a1821ac583ff5a3d25b3bbf1637f01bfb55366b45cc7d5086d1f29f006d615bb658d0e5faab9
-EBUILD gocr-0.50.ebuild 1199 BLAKE2B ab0670e4b0c0af277050a2cf59cdcc5aedae968f061943bde4c6aeebfc161336c1e83f397f20cb37a1adabccdaa4fe36f27c9dc0cc90dd2b2ac96ccd96e75a53 SHA512 d73b4c9f4ed68f3c1f09ed7f2fe45d296c0a4fc74a29fb728e40090367be214e030e3615e50c91c9bc156d26ea9403624790ab9d71d3a0dcbf4c046c0f410cfe
+EBUILD gocr-0.50.ebuild 1197 BLAKE2B 1d40723a64c90656f5a333d9834824e0a9baa8222a24b2f4042f3497b65ab823d9dd276d3036febb9f6461f4f7d07e25443d6a285cb6f6c2f07b86484ab96c6e SHA512 ee96d72859d2e29ff6b5405f49b5e6c102bd4058d6a38e8f319634012b2b21f64ce3cf314deac831312a6fadde23e55ba88b2ce2868919677a1944ab802371ba
MISC metadata.xml 323 BLAKE2B bb09f6949d6fdefdb0ff856c96a0ab766e9ef11559aed7bc424b6da8eb226f4f9090b708da8b4ab62a123530201bfe721e5e6b505b5a6f3d5cd40f48941a86d9 SHA512 5b38ff42ca62ce001e5041406a24ccd8bc1c7f33d7a9e1f84ca0d5d48a3ad2f80e74732a846ffb6768709748bd2dca5868f76ab4c1b00f1e75a6f622597858e1
diff --git a/app-text/gocr/gocr-0.50.ebuild b/app-text/gocr/gocr-0.50.ebuild
index d117bc57f841..80528df1f6e7 100644
--- a/app-text/gocr/gocr-0.50.ebuild
+++ b/app-text/gocr/gocr-0.50.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="An OCR (Optical Character Recognition) reader"
HOMEPAGE="http://jocr.sourceforge.net"
@@ -12,8 +12,12 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc scanner tk"
-DEPEND=">=media-libs/netpbm-9.12
- doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+DEPEND="
+ >=media-libs/netpbm-9.12
+ doc? (
+ >=media-gfx/transfig-3.2
+ app-text/ghostscript-gpl
+ )
tk? ( dev-lang/tk )"
RDEPEND="${DEPEND}
tk? (
@@ -22,24 +26,28 @@ RDEPEND="${DEPEND}
)"
src_compile() {
- local mymakes="src man"
+ local targets=( src man )
+ use doc && targets+=( doc examples )
- use doc && mymakes="${mymakes} doc examples"
-
- emake ${mymakes}
+ emake "${targets[@]}"
}
src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
- dodoc AUTHORS BUGS CREDITS HISTORY RE* TODO
+ einstalldocs
+ dodoc HISTORY REMARK.txt REVIEW
# remove the tk frontend if tk is not selected
- use tk || rm "${ED}"/usr/bin/gocr.tcl
+ if ! use tk; then
+ rm "${ED}"/usr/bin/gocr.tcl || die
+ fi
+
# and install the documentation and examples
- if use doc ; then
+ if use doc; then
dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
- insinto /usr/share/doc/${PF}/examples
- doins "${S}"/examples/*.{fig,tex,pcx}
+
+ docinto examples
+ dodoc examples/*.{fig,tex,pcx}
docompress -x /usr/share/doc/${PF}/examples
fi
}