summaryrefslogtreecommitdiff
path: root/app-text/foliate/foliate-2.6.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-14 16:01:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-14 16:01:32 +0100
commit153fd195574cc30040446316bb666af0e58d985f (patch)
tree657cdfb683dfabd52ff06cb67ddd31b653fb9f43 /app-text/foliate/foliate-2.6.4-r3.ebuild
parent3fa8418e7778f51be61ca1c9114059c73a477459 (diff)
gentoo auto-resync : 14:05:2023 - 16:01:32
Diffstat (limited to 'app-text/foliate/foliate-2.6.4-r3.ebuild')
-rw-r--r--app-text/foliate/foliate-2.6.4-r3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-text/foliate/foliate-2.6.4-r3.ebuild b/app-text/foliate/foliate-2.6.4-r3.ebuild
new file mode 100644
index 000000000000..666dca3a88a1
--- /dev/null
+++ b/app-text/foliate/foliate-2.6.4-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="cs de es eu fr id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit meson python-any-r1 plocale xdg gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4.1[introspection]
+ sys-devel/gettext
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-webkit.patch "${FILESDIR}"/${PN}-validate.patch )
+
+src_prepare() {
+ default
+ python_fix_shebang build-aux/meson
+ xdg_environment_reset
+
+ plocale_find_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_install() {
+ meson_src_install
+ dosym com.github.johnfactotum.Foliate /usr/bin/foliate
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}