summaryrefslogtreecommitdiff
path: root/app-text/flpsed/flpsed-0.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/flpsed/flpsed-0.7.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/flpsed/flpsed-0.7.2.ebuild')
-rw-r--r--app-text/flpsed/flpsed-0.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/flpsed/flpsed-0.7.2.ebuild b/app-text/flpsed/flpsed-0.7.2.ebuild
new file mode 100644
index 000000000000..5e75d7154621
--- /dev/null
+++ b/app-text/flpsed/flpsed-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Pseudo PostScript editor"
+HOMEPAGE="http://flpsed.org/flpsed.html"
+SRC_URI="http://flpsed.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ >=x11-libs/fltk-1.3.0:1
+ app-text/ghostscript-gpl[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch
+}
+
+src_install() {
+ default
+
+ doicon ${PN}.png
+ doicon -s scalable ${PN}.svg
+ domenu ${PN}.desktop
+}