summaryrefslogtreecommitdiff
path: root/app-text/expander
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/expander
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/expander')
-rw-r--r--app-text/expander/Manifest4
-rw-r--r--app-text/expander/expander-2.0.5-r2.ebuild51
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch58
-rw-r--r--app-text/expander/metadata.xml5
4 files changed, 118 insertions, 0 deletions
diff --git a/app-text/expander/Manifest b/app-text/expander/Manifest
new file mode 100644
index 000000000000..6e1bf1b59299
--- /dev/null
+++ b/app-text/expander/Manifest
@@ -0,0 +1,4 @@
+AUX expander-2.0.5-gentoo.patch 1971 BLAKE2B 16459adb991e28472c569ef77bd4f688110e0d2a99970ed65e5332736a1a90a82afa6a04aaec38ba53b16b3303efbe8706324ffe1a37d6b00637550802d23960 SHA512 f81577c3ee11d2e13b59258a59e02a3ec26b265ee2206fde5585f75c21db015907835ade2db88a19ab1afd778a3a7d146d99d1dfb891237d04b2e6a052f49f57
+DIST nedit_expander_kit_2.05.tar.gz 92571 BLAKE2B 0b77640b87372003e873a9e9146aeec82220dfc86b4f6d57220807443c007b6f4f99da8da505d7b6d2f1350150698deed84c8cb710297c6d8646ed192d3ee04a SHA512 a9d5e97db95eec9f98d71360c6af5a6908f31f59221ac1f509ae4f661b0614610b9591b9e2f58bba1175a6b609407d720369ba99cecb5496133d889bf93788ee
+EBUILD expander-2.0.5-r2.ebuild 1094 BLAKE2B a9b380f0fa99cdd32c32423fcfb2fc7a0684e0b92093f39dfe0169093d4eb8ca672cf890841903ad128593a592ed0e4258155c6e984bf0cf6b83297de4970c5e SHA512 1c95a0838980dd94d03257eae7c3c405d3236e0af0b828860a1e9d428788d77beb0add8bbcb8cabed07e7839c164ff44137a189965cd42a0ca1c32fa0620ae01
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/expander/expander-2.0.5-r2.ebuild b/app-text/expander/expander-2.0.5-r2.ebuild
new file mode 100644
index 000000000000..1c4a5c12ffbd
--- /dev/null
+++ b/app-text/expander/expander-2.0.5-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Expander is a utility that acts as a filter for text editors"
+HOMEPAGE="http://www.nedit.org"
+SRC_URI="ftp://ftp.nedit.org/pub/contrib/misc/nedit_expander_kit_2.05.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake -C src CC=$(tc-getCC)
+}
+
+src_install() {
+ cd src
+ dobin expander boxcomment align_columns align_comments where_is
+ dosym boxcomment /usr/bin/unboxcomment
+
+ insinto /usr/share/${P}
+ doins "${S}"/service
+ for x in defs macros misc templates ; do
+ insinto /usr/share/${P}/${x}
+ doins "${S}"/${x}/*
+ done
+
+ cd "${S}"/docs
+ doman *.1
+
+ cd "${S}"
+ dodoc ChangeLog INSTALL README USAGE
+}
+
+pkg_postinst() {
+ elog
+ elog "Instructions for using expander with NEdit are in /usr/share/doc/${PF}/INSTALL"
+ elog "Macro, definition and template files can be found in /usr/share/${P}"
+ elog
+}
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..460a8164cee5
--- /dev/null
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -0,0 +1,58 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,15 +3,14 @@
+ bindir = $(BINDIR)/
+
+ copy = ln -fs
+-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
+-compiler = cc $(CFLAGS)
++compiler = $(CC) $(CFLAGS)
+
+ executables = expander boxcomment align_columns align_comments where_is
+
+ #--------------
+ # Build Targets
+ #--------------
+-all: verify $(executables)
++all: $(executables)
+
+ verify:
+ @if [ "$(bindir)" = "/" ]; then \
+@@ -24,32 +23,31 @@
+ # Abbreviation expansion filter program (with NEdit, language sensitive)
+ #-----------------------------------------------------------------------
+ expander: expander.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #--------------------------------------------------------------------------
+ # Surround given text with open ended box. (with NEdit, language sensitive)
+ #--------------------------------------------------------------------------
+ boxcomment: boxcomment.c
+- $(compiler) -o $(bindir)$@ $?
+- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #-------------------------------------------------------------------------------
+ # Align ragged looking 'C' style comments (good substitute for align_equals too)
+ #-------------------------------------------------------------------------------
+ align_comments: align_comments.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------
+ # Align given text in columns
+ #----------------------------
+ align_columns: align_columns.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------------------------
+ # File locator (substitute for which, where...)
+ #----------------------------------------------
+ where_is: where_is.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #------------------------------------------------
+ # Here is how to uninstall the executables built.
diff --git a/app-text/expander/metadata.xml b/app-text/expander/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/expander/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>