summaryrefslogtreecommitdiff
path: root/app-text/enscript/enscript-1.6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/enscript/enscript-1.6.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/enscript/enscript-1.6.6.ebuild')
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
new file mode 100644
index 000000000000..185ba15dbf84
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Powerful text-to-postscript converter"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.gnu.org/software/enscript/enscript.html"
+
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="nls ruby"
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/enscript-1.6.4-ebuild.st.patch
+ epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
+ use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
+ sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ebuild.st
+
+ if use ruby ; then
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ruby.st
+ fi
+}