summaryrefslogtreecommitdiff
path: root/app-text/enscript/enscript-1.6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/enscript/enscript-1.6.6.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/enscript/enscript-1.6.6.ebuild')
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
index b613378cc142..bb889e8b0db3 100644
--- a/app-text/enscript/enscript-1.6.6.ebuild
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Powerful text-to-postscript converter"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
@@ -14,20 +14,26 @@ SLOT="0"
LICENSE="GPL-3"
IUSE="nls ruby"
-DEPEND="
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/flex
sys-devel/bison
nls? ( sys-devel/gettext )
"
-RDEPEND="nls? ( virtual/libintl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.4-ebuild.st.patch
+ "${FILESDIR}"/${PN}-1.6.5.2-php.st.patch
+ "${FILESDIR}"/${PN}-1.6.4-fsf-gcc-darwin.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/enscript-1.6.4-ebuild.st.patch
- epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
- epatch "${FILESDIR}"/enscript-1.6.4-fsf-gcc-darwin.patch
- use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
- sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
default
+
+ use ruby && eapply "${FILESDIR}"/enscript-1.6.2-ruby.patch
+
+ sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
}
src_configure() {