summaryrefslogtreecommitdiff
path: root/app-text/dvipng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/dvipng
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/dvipng')
-rw-r--r--app-text/dvipng/Manifest5
-rw-r--r--app-text/dvipng/dvipng-1.15-r1.ebuild49
-rw-r--r--app-text/dvipng/dvipng-1.15.ebuild39
-rw-r--r--app-text/dvipng/files/dvipng-1.15-freetype-config.patch12
-rw-r--r--app-text/dvipng/metadata.xml29
5 files changed, 134 insertions, 0 deletions
diff --git a/app-text/dvipng/Manifest b/app-text/dvipng/Manifest
new file mode 100644
index 000000000000..19cf5b581d39
--- /dev/null
+++ b/app-text/dvipng/Manifest
@@ -0,0 +1,5 @@
+AUX dvipng-1.15-freetype-config.patch 405 BLAKE2B cb60958773b1091026f4bd59cab2dbb51404a3696f61606a4394563b70e2d4a506664d91435b9485417fa8ef61a07051240b8d05861f4bf1e0196a93de69966e SHA512 65fb9900e0b929902713a0c61e5bd2cafd56828a0f294171852bd7d6a5ee44356a26e3f5a3bc57f5e0c532cc6e31a8111ca1daf52945909eecd7b7f1c74c3546
+DIST dvipng-1.15.tar.gz 171529 BLAKE2B 0653e1b6cace30cd510c0a4f7a5ac4c88d3e17a6283693b93202529b1453dcc1617ed5906112206bfb872af093d871163cc6a117be13575211712901ac541070 SHA512 54647526a9d3a26d2ba9c7ef17f285a426d9df06ffb1d5336a1da95cbf24cd17505ba7f6b1ffd14a0beb7f91ab3e519612ce3d3ea3f30c278733127dfbf07c5c
+EBUILD dvipng-1.15-r1.ebuild 1307 BLAKE2B 2619278b779ec4dc561243e6ae0b17681f6a300b4cf4dd85416c621fbaa41c043461fef86e564a0fab2846c7e151a545ef8ebaaa6ca71d9b25bcb0813a9b18c9 SHA512 652146959955e0d6be1dfddbbfe4690d9d990b94fee92aa6a443d3380a27bc14b1f7595ac7ffd216e6cf1e57fcb5aee166baefb6d9d371825e86cd956b2856c1
+EBUILD dvipng-1.15.ebuild 1121 BLAKE2B 3975d100ff1722886fc277ad7d37584bce315d6e3ced9e5cb62e86bab7430483cbf6bd6dba30fc2227097e9b6e247c7b65bf8590dad4c70476205f579b2b277d SHA512 95692a71c955e8d9ff08b32171831148aa455a60b765e2b1beea7687da1eeb1d8e7b9f0acd9c8da4a3f2173f26f1b77f6c2d67210d538eed25a88f80075eb82f
+MISC metadata.xml 1122 BLAKE2B fcfe5bf7616dd40ccaa74751ba1c653012de0f263ae8c4764363c4a5b1ce9546a335b7e2c0917a9d2a0a30cde98bcc5b8e3184619b83f1d6267d7172584144d2 SHA512 c2f663c6ae8113fc462e16ce50ef44172c8d5cffaf34e9095701df7e3ae568126bb782c8a02e3d735239ea7263e6cd9778bf21f4d7166c24799a9090ecd8bc26
diff --git a/app-text/dvipng/dvipng-1.15-r1.ebuild b/app-text/dvipng/dvipng-1.15-r1.ebuild
new file mode 100644
index 000000000000..14d8b025c605
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.15-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="truetype test"
+
+RDEPEND="
+ >=dev-libs/kpathsea-6.2.1:=
+ media-libs/gd:2=[jpeg,png]
+ media-libs/libpng:0=
+ virtual/latex-base
+ sys-libs/zlib
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ virtual/pkgconfig
+ test? ( dev-texlive/texlive-fontsrecommended )"
+
+DOCS="ChangeLog README RELEASE"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-freetype-config.patch
+ eapply_user
+
+ # save local macros, since we regenerate aclocal.m4 below
+ mv aclocal.m4 acinclude.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ if ! use truetype; then
+ sed -i -e 's/\(--exists.*\)freetype2/\1dIsAbLe/' configure \
+ || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}
diff --git a/app-text/dvipng/dvipng-1.15.ebuild b/app-text/dvipng/dvipng-1.15.ebuild
new file mode 100644
index 000000000000..6b0df705d059
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="truetype test"
+
+RDEPEND="
+ dev-libs/kpathsea:=
+ media-libs/gd:2=[jpeg,png]
+ media-libs/libpng:0=
+ virtual/latex-base
+ sys-libs/zlib
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ virtual/pkgconfig
+ test? ( dev-texlive/texlive-fontsrecommended )"
+
+DOCS="ChangeLog README RELEASE"
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ if ! use truetype; then
+ sed -i -e 's/FT_Init_FreeType/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}
diff --git a/app-text/dvipng/files/dvipng-1.15-freetype-config.patch b/app-text/dvipng/files/dvipng-1.15-freetype-config.patch
new file mode 100644
index 000000000000..20b7ebaf465c
--- /dev/null
+++ b/app-text/dvipng/files/dvipng-1.15-freetype-config.patch
@@ -0,0 +1,12 @@
+--- dvipng-1.15-orig/configure.ac
++++ dvipng-1.15/configure.ac
+@@ -78,7 +78,8 @@
+ AC_CHECK_HEADERS([libgen.h])
+ PSFONTS_O=""
+ AC_SUBST(PSFONTS_O)
+-AC_CHECK_FT2(,[CFLAGS="$FT2_CFLAGS $CFLAGS"
++PKG_CHECK_MODULES([FT2], [freetype2 >= 6.1.0],
++ [CFLAGS="$FT2_CFLAGS $CFLAGS"
+ LIBS="$FT2_LIBS $LIBS"
+ PSFONTS_O="sfd.o ft.o enc.o fontmap.o tfm.o"
+ AC_DEFINE(HAVE_FT2, 1, [Define to 1 if you have freetype2])
diff --git a/app-text/dvipng/metadata.xml b/app-text/dvipng/metadata.xml
new file mode 100644
index 000000000000..08df7bc3b39c
--- /dev/null
+++ b/app-text/dvipng/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<longdescription>
+ This program makes PNG and/or GIF graphics from DVI files as obtained
+ from TeX and its relatives.
+
+ If GIF support is enabled, GIF output is chosen by using the ‘dvigif’
+ binary or with the ‘--gif’ option.
+
+ It is intended to produce anti-aliased screen-resolution images as fast
+ as is possible. The target audience is people who need to generate and
+ regenerate many images again and again. The primary target is the
+ preview-latex (X)Emacs package, a package to preview formulas from within
+ (X)Emacs. Yes, you get to see your formulas in the (X)Emacs buffer, see
+ &lt;https://www.gnu.org/software/auctex/preview-latex.html&gt;.
+</longdescription>
+<upstream>
+ <remote-id type="sourceforge">dvipng</remote-id>
+</upstream>
+</pkgmetadata>