summaryrefslogtreecommitdiff
path: root/app-text/dvipng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/dvipng
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/dvipng')
-rw-r--r--app-text/dvipng/Manifest5
-rw-r--r--app-text/dvipng/dvipng-1.15.ebuild39
-rw-r--r--app-text/dvipng/metadata.xml29
3 files changed, 73 insertions, 0 deletions
diff --git a/app-text/dvipng/Manifest b/app-text/dvipng/Manifest
new file mode 100644
index 000000000000..045f3dc5f082
--- /dev/null
+++ b/app-text/dvipng/Manifest
@@ -0,0 +1,5 @@
+DIST dvipng-1.15.tar.gz 171529 SHA256 197e9fd0f87ede32dc4bc1d39ec2cd72fa5260856f9d0dc2d8e6895130408347 SHA512 54647526a9d3a26d2ba9c7ef17f285a426d9df06ffb1d5336a1da95cbf24cd17505ba7f6b1ffd14a0beb7f91ab3e519612ce3d3ea3f30c278733127dfbf07c5c WHIRLPOOL 4c0c5e410b107cd6cb56f9360acd556ae4336855d0624800d96e46cd29caead0467bc554d3d1c404e4564a3ce7b3732386f6af93ea98312c6b17745582f4ef92
+EBUILD dvipng-1.15.ebuild 1121 SHA256 ca0b6b026c462dd2f71ca9c05540e8645c024fe1e9139c287486a5469fb64955 SHA512 95692a71c955e8d9ff08b32171831148aa455a60b765e2b1beea7687da1eeb1d8e7b9f0acd9c8da4a3f2173f26f1b77f6c2d67210d538eed25a88f80075eb82f WHIRLPOOL d50860ed69120ed223c162efbfe0d1f3396fe2c63d0ef54790a2dcc78e27b37218d47f50773aeaa911aab29054a6b333c55c64709dd54a546df500fb6dcba42e
+MISC ChangeLog 4692 SHA256 4c54f263d0d8c8d7b6ae6415db189e0cd177ef8751e21f300d23f3cb8bd0f74b SHA512 5c8a36ad303018a74a9bcb0860b0cfecf353ea619eda7c4d39030fe2c48cc9d15f229862803291e48b59bc3790d51c99844de00c08f872e35e42ce3fce0bf49d WHIRLPOOL 953e41959b378d4335f96292935ba9afcace76f68f9a7638087eeccfc9f1d17ed4163c485033e3fd00ca984a31a5f2123f734db657b608c9240bd184f6b59fb3
+MISC ChangeLog-2015 10782 SHA256 1c85522affe248b12676053046b7254975a2da52e4ed352c870b05b0e1ae4e0a SHA512 6a783ae9c85b5b3d57aab6658f0b482fa3d7b40eb3689daf10f7863d73aa98a97a0a4cd583b9df0677cde2d1b813108fe37aef9c2052bee20a9403f8145e2c8c WHIRLPOOL 06afe5ba493f4b8fd653bf2be0bdea3164037077d6cf7f44645cb176d59a9fbd9e70d3fb6a50169fc46e56bae19839db3a182f87e2c208147d68b52cfba4c418
+MISC metadata.xml 1122 SHA256 df214d66d5d49875741bababf44bdabf36b6a2bcd3ba05c166e12b3eedbd4a04 SHA512 c2f663c6ae8113fc462e16ce50ef44172c8d5cffaf34e9095701df7e3ae568126bb782c8a02e3d735239ea7263e6cd9778bf21f4d7166c24799a9090ecd8bc26 WHIRLPOOL 23ef33769e2dbc4a491df92f30425719b614393b82c42f42d4b232ab2dc51e2bd40888b4e8740f9c376ec5647e5f968314bb409b81f2549c0f2c9d8203b75d43
diff --git a/app-text/dvipng/dvipng-1.15.ebuild b/app-text/dvipng/dvipng-1.15.ebuild
new file mode 100644
index 000000000000..6b0df705d059
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="truetype test"
+
+RDEPEND="
+ dev-libs/kpathsea:=
+ media-libs/gd:2=[jpeg,png]
+ media-libs/libpng:0=
+ virtual/latex-base
+ sys-libs/zlib
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ virtual/pkgconfig
+ test? ( dev-texlive/texlive-fontsrecommended )"
+
+DOCS="ChangeLog README RELEASE"
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ if ! use truetype; then
+ sed -i -e 's/FT_Init_FreeType/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}
diff --git a/app-text/dvipng/metadata.xml b/app-text/dvipng/metadata.xml
new file mode 100644
index 000000000000..08df7bc3b39c
--- /dev/null
+++ b/app-text/dvipng/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<longdescription>
+ This program makes PNG and/or GIF graphics from DVI files as obtained
+ from TeX and its relatives.
+
+ If GIF support is enabled, GIF output is chosen by using the ‘dvigif’
+ binary or with the ‘--gif’ option.
+
+ It is intended to produce anti-aliased screen-resolution images as fast
+ as is possible. The target audience is people who need to generate and
+ regenerate many images again and again. The primary target is the
+ preview-latex (X)Emacs package, a package to preview formulas from within
+ (X)Emacs. Yes, you get to see your formulas in the (X)Emacs buffer, see
+ &lt;https://www.gnu.org/software/auctex/preview-latex.html&gt;.
+</longdescription>
+<upstream>
+ <remote-id type="sourceforge">dvipng</remote-id>
+</upstream>
+</pkgmetadata>