summaryrefslogtreecommitdiff
path: root/app-text/dos2unix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /app-text/dos2unix
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/Manifest2
-rw-r--r--app-text/dos2unix/dos2unix-7.4.4.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index fd106ff1b48b..0aa578c6e186 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1,3 +1,5 @@
DIST dos2unix-7.4.3.tar.gz 788278 BLAKE2B da959b06e583bbf27a2cb2ce5b1f1a41380722aa09ac75b3d31260e92fd6f1203d87266d3a12201b036a69796b4aa4f23718741036e20fe686801bb368fbde22 SHA512 1c6d81348de8aca451174794141d0802685487cf6847fa91f7de745d89bcf2af864fc2ec549b9af72031891d4efcb9731fe823ce05da36d1f9e9890ff2cb60fb
+DIST dos2unix-7.4.4.tar.gz 914647 BLAKE2B eb8d33344780bb15201eed571d7a6a21db0bc13e8e94388c70e1daea84cc0d1dfb9f16b7ed1cd216bb31ffd84dee706e7f2fb46050a299602f7c67c53915ded9 SHA512 e7a6b1d90bf0a32aa53b22caa1660dcf58c5874d02a45e80f4cc811cae9bd7b0cb8144301fb6808798100a057c03210925da1d8461e380dff1059f6bee086f55
EBUILD dos2unix-7.4.3.ebuild 2124 BLAKE2B 926692e61a59b1faeae5c60f3a2c0cac80e0496da2018896fc59603991b008f970a5d73a43f9199fafa480c167238e968e5b5301d88663488bff58b212b67e7a SHA512 480e3539f63c8b7a1f5e884004976c715927a8078cc08eaa1689c15761974008d190c178ea98cadeffdd625a45b3af3bf4aa0c9b987257080224a1b6ca84331c
+EBUILD dos2unix-7.4.4.ebuild 2146 BLAKE2B 1bf975aef1c01fdab5470cdb4c48b07d79d947448eacce1009600e05541a8827e35d593b9bb8f5b0e4fb70fc285f0346fa1bd6318aa1f3b6498c313dfc86049f SHA512 59b3357de6dbd65c9d750c5c5f72a5363effcf41b01040f1f58d762787fbf5c1180677c0f5cb4d1b0e1ea8dede500db7457339beca0cb97e664f55a06db63ae6
MISC metadata.xml 344 BLAKE2B ec6c66c1693ed09d8434840bb0e5eaf6689d629c787a115eedad537972c06c3aae6d739cd55a9acf85ed21043314e9721030b7c570c85eea4361c083d7db9fe1 SHA512 63d5baa4e84950d6cb2fd604f93e60842bc210af298eef73bc9e59e3d811957b99a95e2538ddd6df7d2ac6a50e30ff5bda66af4d7dbb573cec4ef83a38e42919
diff --git a/app-text/dos2unix/dos2unix-7.4.4.ebuild b/app-text/dos2unix/dos2unix-7.4.4.ebuild
new file mode 100644
index 000000000000..5c0b6d2870e4
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.4.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="ca da de eo es fr fur hu ja ka ko nb nl pl pt_BR ro ru sr sv uk vi zh_CN zh_TW"
+
+inherit plocale toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="https://www.xs4all.nl/~waterlan/dos2unix.html https://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ https://www.xs4all.nl/~waterlan/${PN}/${P/_/-}.tar.gz
+ mirror://sourceforge/${PN}/${P/_/-}.tar.gz
+"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+BDEPEND="
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+"
+
+RESTRICT="!test? ( test )"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ plocale_for_each_disabled_locale rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_musl && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}