summaryrefslogtreecommitdiff
path: root/app-text/dos2unix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/dos2unix
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/Manifest2
-rw-r--r--app-text/dos2unix/dos2unix-7.4.3.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index 0538599b5758..d501e4680dbe 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1,3 +1,5 @@
DIST dos2unix-7.4.2.tar.gz 727429 BLAKE2B 5ba8aecfe3a79dfe9f4d7d69453fdcdd573c8889b41240c6bce5fea1b7e9e8213454af98f768cb2d199c85684a7d48192ba4bf856a92b867594b52a2209d5e04 SHA512 3fb77561596bafd83f3f7807ce967e58d5a96e5235afe3a4074ae7112297445690b2586bf652eb0b5bd1984fd41a79478355f6df8244561b4167a8a09593110d
+DIST dos2unix-7.4.3.tar.gz 788278 BLAKE2B da959b06e583bbf27a2cb2ce5b1f1a41380722aa09ac75b3d31260e92fd6f1203d87266d3a12201b036a69796b4aa4f23718741036e20fe686801bb368fbde22 SHA512 1c6d81348de8aca451174794141d0802685487cf6847fa91f7de745d89bcf2af864fc2ec549b9af72031891d4efcb9731fe823ce05da36d1f9e9890ff2cb60fb
EBUILD dos2unix-7.4.2.ebuild 2125 BLAKE2B fa03a4333664fe3b4cb65edb3300fdc25e4c6f3cda983c7ed4bacb30c7f95697ce65189398f7fa649c61bbb20561419c8c8cf2e426463d5e0e85a02f94f84026 SHA512 daf015eefbc369c84b0a7c0043d47dd395b26ed8917098e276d1c408ad57468adc01d4c6f9ba4556b2aef48bebe10c23c1a0687c8b7c9478717dfb1f086f14e5
+EBUILD dos2unix-7.4.3.ebuild 2131 BLAKE2B 825cb97a9cc6998568f67fe0da56229dc4cbb56b2d00d77a4b1b9ac518050e3dbe6ffa766e9feac6fe3c6d97632ce0d306dc27a968f11184ef74bf45d9491998 SHA512 ced6647e1f4a9874a34b246fffdd2adf9f2a0189fc5fcae23305d20863c7bb8ad270cd17717a7ca7a3b9ef170bd7144602e98ca3f5a38913bbb23365e6868917
MISC metadata.xml 344 BLAKE2B ec6c66c1693ed09d8434840bb0e5eaf6689d629c787a115eedad537972c06c3aae6d739cd55a9acf85ed21043314e9721030b7c570c85eea4361c083d7db9fe1 SHA512 63d5baa4e84950d6cb2fd604f93e60842bc210af298eef73bc9e59e3d811957b99a95e2538ddd6df7d2ac6a50e30ff5bda66af4d7dbb573cec4ef83a38e42919
diff --git a/app-text/dos2unix/dos2unix-7.4.3.ebuild b/app-text/dos2unix/dos2unix-7.4.3.ebuild
new file mode 100644
index 000000000000..65a984556454
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.4.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="da de eo es fr fur hu ja nb nl pl pt_BR ru sr sv uk vi zh_CN zh_TW"
+
+inherit plocale toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html https://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P/_/-}.tar.gz
+ mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+BDEPEND="
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+"
+
+RESTRICT="!test? ( test )"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ plocale_for_each_disabled_locale rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_musl && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}