summaryrefslogtreecommitdiff
path: root/app-text/doconce
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/doconce
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/doconce')
-rw-r--r--app-text/doconce/Manifest5
-rw-r--r--app-text/doconce/doconce-1.3.ebuild16
-rw-r--r--app-text/doconce/doconce-1.4.4.ebuild26
-rw-r--r--app-text/doconce/metadata.xml20
4 files changed, 67 insertions, 0 deletions
diff --git a/app-text/doconce/Manifest b/app-text/doconce/Manifest
new file mode 100644
index 000000000000..e0bc64fbf8d7
--- /dev/null
+++ b/app-text/doconce/Manifest
@@ -0,0 +1,5 @@
+DIST doconce-1.3.tar.bz2 112034753 BLAKE2B 4ac826b09ca2dce93d8725868f6fa00a07b61835336a56b72f4d846cb81282cc6982ca25c7fc27d9e66aed5a22d3ef30badbc137748f7c6c3a2e078554b6715e SHA512 b59568e801f4cc5b7f01f3c3d344702ec80c65b5a065e2ece3b3ed8cb5f669739c9adf3caf96cd0b43c646ccae0f11325d5ca64ee1a325ac404ec6e5feb6148d
+DIST doconce-1.4.4.tar.bz2 112713371 BLAKE2B 65acba4d02095d616c5ca6a070bb4a80ae57b4f201d9810f7b88e212e1ea86bd211440213194c4d61a2eefd19dfa9de9f81376d3e535f032747a8102bfdc2160 SHA512 9b5caae789a395bcdbb4daeea57182f2ea21a2c3c4da0abae2c097351fece601da6901de8d89ab60a187c1bc0ba5f913bbee14a847c1f85020dc16e0cdffdf31
+EBUILD doconce-1.3.ebuild 509 BLAKE2B f05c8416ac6cf3963229007f51b538384181c6332a73ee4ed4cac73dcc2e88b0cfe76665fc26dba0ebbe5a52b6b3244bd4d4daa738de37f54fa19da8e0b82345 SHA512 c54d6797c6f8397c7b4de5f8d5036d20481000105a85d5e4ebf06246d76d084b5370b811d8bbdc88164c7366231ccf53666f7788309f871260b161091478653c
+EBUILD doconce-1.4.4.ebuild 781 BLAKE2B b0440491855d426fbb79fd529e639b3721737722ec4f27bc16fa97f5e5648890a8de411a60468efa9bf0492aa98032c449283acc4b24141830e868c28cb65741 SHA512 f144b7160e38817ef00c443f2083fe854775023db6df98f30bdb9943cde6705bb25aa04fb490084efbc1485da4d21ef4ac142d62cb85a7e8413ef2f5943eca0e
+MISC metadata.xml 886 BLAKE2B 0e17aef2ca8b68603b8d8b83d719d6224e3891594c07070acebfa25c22b7860e92dcc0cd856227626299c1d5f12d04f7e279afea75b7bb508854ea9ea15ecdf6 SHA512 51fd63b9e6ebef041891046676a22e11eb4addefa5730632f48843509fdfb7cb16d612b55941222d690a305ee50cf2d66557bdde64f6db35c71efe39019ca55b
diff --git a/app-text/doconce/doconce-1.3.ebuild b/app-text/doconce/doconce-1.3.ebuild
new file mode 100644
index 000000000000..065c118dc878
--- /dev/null
+++ b/app-text/doconce/doconce-1.3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="A markdown-like langauge to generate docs in html, LaTeX, and many other formats"
+HOMEPAGE="https://github.com/hplgit/doconce/ https://pypi.org/project/doconce/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND="dev-python/future"
+RDEPEND="${DEPEND}"
diff --git a/app-text/doconce/doconce-1.4.4.ebuild b/app-text/doconce/doconce-1.4.4.ebuild
new file mode 100644
index 000000000000..8752b80e9b24
--- /dev/null
+++ b/app-text/doconce/doconce-1.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A markdown-like langauge to generate docs in html, LaTeX, and many other formats"
+HOMEPAGE="https://github.com/hplgit/doconce/ https://pypi.org/project/Doconce/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ default
+ if use doc; then
+ sed -e "s|http://hplgit.github.io/doconce/doc|file:///usr/share/doc/${PF}|g" -i doc/web/index.html
+ docompress -x /usr/share/doc
+ dodoc -r doc/web doc/pub
+ fi
+}
diff --git a/app-text/doconce/metadata.xml b/app-text/doconce/metadata.xml
new file mode 100644
index 000000000000..b9c4307747b0
--- /dev/null
+++ b/app-text/doconce/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
+ DocOnce is a modestly tagged (Markdown-like) markup language targeting scientific reports,
+ software documentation, books, blog posts, and slides involving much math and code in the text.
+ From DocOnce source you can generate LaTeX, Sphinx, HTML, IPython notebooks, Markdown,
+ MediaWiki, and other formats.
+ This means that you from a single source can get the most up-to-date publishing technologies
+ for paper, tablets, and phones.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">Doconce</remote-id>
+ <remote-id type="github">hplgit/doconce</remote-id>
+ </upstream>
+</pkgmetadata>