summaryrefslogtreecommitdiff
path: root/app-text/docbook-xsl-stylesheets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 11:36:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 11:36:37 +0100
commitd6fe3a53bdeea6b060d1755199cc2c27492dc14c (patch)
tree7bb8240ab620eafcfe59b3d1b45831bf45e12501 /app-text/docbook-xsl-stylesheets
parent4bbcd26e7cb1908fb98bb318bfaa13ea9e32d860 (diff)
gentoo auto-resync : 10:04:2023 - 11:36:36
Diffstat (limited to 'app-text/docbook-xsl-stylesheets')
-rw-r--r--app-text/docbook-xsl-stylesheets/Manifest1
-rw-r--r--app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/app-text/docbook-xsl-stylesheets/Manifest b/app-text/docbook-xsl-stylesheets/Manifest
index 0fa0283d9a42..455b6a66bef2 100644
--- a/app-text/docbook-xsl-stylesheets/Manifest
+++ b/app-text/docbook-xsl-stylesheets/Manifest
@@ -1,4 +1,5 @@
AUX nonrecursive-string-subst.patch 1205 BLAKE2B 0c7bb8e3ba646a137bc0b50722448c65437881672a4bbb3f3dc7a181e5074f667fca0fbcb4475b83f04ac63bdddbf3dae800b7a7094b5d9aea270faeb81d9e50 SHA512 6a26838078a3ce28273dddfa1af6a378cffc28b6d1ba48a4cfc839addd7bf58ce217d6584b735f9c75381954744ab2386c75fa3c593858b6e27882be55c00d04
DIST docbook-xsl-1.79.1.tar.bz2 21967928 BLAKE2B 42b7e989616d16fa100c2dad713830ecedf6c7e26f56f99a9bf9330385c753f282cea1033e689196352bd41f9dca59a06ff09fc4638051cb478a630df9bfeb0b SHA512 83325cbaf1545da6b9b8b77f5f0e6fdece26e3c455164b300a1aa3d19e3bd29ae71fd563553a714a5394968d1a65684c6c7987c77524469358d18b8c227025c7
EBUILD docbook-xsl-stylesheets-1.79.1-r3.ebuild 2251 BLAKE2B 18286bcab2e0eac49b74b49ac241f0d9e0b0cf799c50f259455991a94a9cc49642c507e8e3365b57d9a3cd88654523007978444854c0e7239d3e81a71b3443a0 SHA512 258872fb8224ca0699025a8a9a8990b981e4595f5b2e538078fe266c0bb06ae844daa132d7d4171abc49721e07df1cba4eeab894844cad6f5e3ed18e334ac81c
+EBUILD docbook-xsl-stylesheets-1.79.1-r4.ebuild 2281 BLAKE2B af5b453297c44bb2c89b2ec46b019bdd3861b3ae0bb3ac5c6f025f6d2690c66c84766278bfc5b0f235e705434c5ef5c11194c89bcdbe75c1966c2e84efe3416a SHA512 60804c15a3959ab5997a01703036e269190e80053c61cff087aa29b1d8fbfa68f79e8cf60435a6d21f69214c8aeb44917573033919e8eb710f95463576f26d7a
MISC metadata.xml 414 BLAKE2B f10f5576731ded90514b956bb032bf6472634a509e709e998b0120ced275cea6d7027b18623b8f7d8198b6137a9566eab1b0462626a20693655c791b9763952e SHA512 f844b8d60c1c3413b8eb647bdffba6fb08e09e7f62df9e122ad6d69f9f67ec67711a66ec840f1ef92edefef83bd5e77103a10b0feeeb4a08f98680274c3dd93a
diff --git a/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild
new file mode 100644
index 000000000000..e47ba4f5bdda
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+inherit ruby-single
+
+DOCBOOKDIR="/usr/share/sgml/${PN/-//}"
+MY_PN="${PN%-stylesheets}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="https://github.com/docbook/wiki/wiki"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ruby"
+# Makefile is broken since 1.76.0
+RESTRICT="test"
+
+RDEPEND="
+ >=app-text/build-docbook-catalog-1.1
+ ruby? ( ${RUBY_DEPS} dev-ruby/rexml )
+"
+
+PATCHES=(
+ "${FILESDIR}"/nonrecursive-string-subst.patch
+)
+
+src_prepare() {
+ default
+
+ # Delete the unnecessary Java-related stuff and other tools as they
+ # bloat the stage3 tarballs massively. See bug #575818.
+ rm -rv extensions/ tools/ || die
+ find \( -name build.xml -o -name build.properties \) \
+ -printf "removed %p\n" -delete || die
+
+ if ! use ruby; then
+ rm -rv epub/ || die
+ fi
+}
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+
+ insinto ${DOCBOOKDIR}
+ doins VERSION VERSION.xsl
+
+ local i
+ for i in */; do
+ i=${i%/}
+
+ for doc in ChangeLog README; do
+ if [[ -e ${i}/${doc} ]]; then
+ newdoc ${i}/${doc} ${doc}.${i}
+ rm ${i}/${doc} || die
+ fi
+ done
+
+ doins -r ${i}
+ done
+
+ if use ruby; then
+ local cmd="dbtoepub${MY_PN#docbook-xsl}"
+
+ # we can't use a symlink or it'll look for the library in the wrong path
+ newbin - ${cmd} <<-EOF
+ #!/usr/bin/env ruby
+
+ load "${EPREFIX}${DOCBOOKDIR}/epub/bin/dbtoepub"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ # See bug #816303 for rationale behind die
+ build-docbook-catalog || die "Failed to regenerate docbook catalog. Is /run mounted?"
+}
+
+pkg_postrm() {
+ # See bug #816303 for rationale behind die
+ build-docbook-catalog || die "Failed to regenerate docbook catalog. Is /run mounted?"
+}