summaryrefslogtreecommitdiff
path: root/app-text/djvu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/djvu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/djvu')
-rw-r--r--app-text/djvu/Manifest6
-rw-r--r--app-text/djvu/djvu-3.5.25.3.ebuild72
-rw-r--r--app-text/djvu/djvu-3.5.27.ebuild63
-rw-r--r--app-text/djvu/files/djvu-3.5.24-gcc46.patch40
-rw-r--r--app-text/djvu/metadata.xml21
5 files changed, 202 insertions, 0 deletions
diff --git a/app-text/djvu/Manifest b/app-text/djvu/Manifest
new file mode 100644
index 000000000000..c3dad1871688
--- /dev/null
+++ b/app-text/djvu/Manifest
@@ -0,0 +1,6 @@
+AUX djvu-3.5.24-gcc46.patch 859 BLAKE2B c11a240b930df4ddbf45272c2c2ba262b545d440cb6553107bac51894853b1ae28ca97620bef74bdde6ac674eee237cf14c63fa9313f9acf2afb70c8e6045f6e SHA512 8e27341bb994dca8ea27cf6da1141f06b5c96f1b853e7d4215214893c32a17fe3adc821c98ff8793d23cde458420f944b7f4d51e794fda9a061fea6f1eac08ca
+DIST djvulibre-3.5.25.3.tar.gz 2543949 BLAKE2B 8ae6004e74a7db0fa666a3cf15f5a3b335690984838e8d674ccd7fa7dda0728771f6fab5f61747b505646e3bb206effd0bbaf9c6035fb27993d587693ad1fa43 SHA512 0e38f56d77915ee6707dd19a36a8ca9167608c39449a5c73de9cd784d712852c07c068b79a794e25f6d3ded0f927d083413dde197c9fc8f7b68c03cffe68035b
+DIST djvulibre-3.5.27.tar.gz 3648522 BLAKE2B e1907b4b64c48304ceb24360cfd451e4690d38803f22231d4e136dbe754715527fa0300c623bb709fa05bba206348257137b2a755651bb51ca26259680e142d0 SHA512 62abcaa2fe7edab536477929ba38b882453dab1a06e119a3f838b38d5c61f5d8c252e4769e6534582b826e49bcfb490513179580fab9c3afa84aa92053ccebee
+EBUILD djvu-3.5.25.3.ebuild 1768 BLAKE2B 9e2806c9af331c5ec9f86a6908ba985d64cee22d64848bff5f80a0cf8163fad0ee2f5736d28260c15c672970b05f20fb1b5ed5f82feb193550186059d548adff SHA512 08d9199c719032df599b8e18022411adbc0ee6f9f5e09e0a8e73b62b13e5e3dc4be6b8baad13dfb4bed973423042c9c464ac714a614af2e771dae7955bf5f453
+EBUILD djvu-3.5.27.ebuild 1461 BLAKE2B 2d8e41aa8552fef138db4660b83ec949892c3254dc902d47d3555592becfbeeaa76cd8d7a5b48ac183a66f9c4a2c351edfe3dd2b2d30a8893bde24936a5a9c7c SHA512 532db3244d98404e095a0521e6ee09724bfe887f374a0b132efd0bae94ad063177562c3c81c0206979f38736a77a392e82ea96e9d0eb2abb62445807eec259cd
+MISC metadata.xml 948 BLAKE2B 1d15a217967f10397d747f2cc0844ea76d4f876ed0ee8cb56733b74a3b92f023e3eeff11bfcb4265766c14dad4b1e35a18f7d2fdd7442068bf82c4a8302690db SHA512 e5cfa3a2b2077a3f0dbfcc99165fb678e8c8759724790d520f1bed670fed5e753a47207bbbcd7d2ff2d55def5b34bf32201771918c9e7a16583d91553ac75e42
diff --git a/app-text/djvu/djvu-3.5.25.3.ebuild b/app-text/djvu/djvu-3.5.25.3.ebuild
new file mode 100644
index 000000000000..455ebfa772e0
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.25.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic xdg-utils
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities"
+HOMEPAGE="http://djvu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug doc jpeg tiff xml"
+
+RDEPEND="jpeg? ( virtual/jpeg:0 )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}
+ || ( gnome-base/librsvg media-gfx/inkscape )"
+
+S=${WORKDIR}/${MY_P%%.3}
+
+src_prepare() {
+ sed -i \
+ -e 's/AC_CXX_OPTIMIZE/OPTS=;AC_SUBST(OPTS)/' \
+ configure.ac || die #263688
+ rm aclocal.m4 config/{libtool.m4,ltmain.sh,install-sh,config.sub,config.guess,ltoptions.m4,ltversion.m4,lt~obsolete.m4}
+# epatch "${FILESDIR}/${PN}-3.5.24-gcc46.patch"
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
+
+ # We install all desktop files by hand.
+ econf \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ --disable-desktopfiles
+}
+
+DOCS=( NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+
+ use doc && dodoc -r doc
+
+ # Install desktop files.
+ cd desktopfiles
+ for i in {22,32,48,64}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
+ newins hi${i}-djvu.png image-vnd.djvu.png
+ done
+ insinto /usr/share/mime/packages
+ doins djvulibre-mime.xml
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ has_version app-text/djview || \
+ optfeature "For djviewer or browser plugin" app-text/djview
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}
diff --git a/app-text/djvu/djvu-3.5.27.ebuild b/app-text/djvu/djvu-3.5.27.ebuild
new file mode 100644
index 000000000000..7e1a7c1c755e
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.27.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic xdg-utils
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities"
+HOMEPAGE="http://djvu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug doc jpeg tiff xml"
+
+RDEPEND="jpeg? ( virtual/jpeg:0 )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}
+ || ( gnome-base/librsvg media-gfx/inkscape )"
+
+S=${WORKDIR}/${MY_P%%.3}
+
+src_configure() {
+ use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
+
+ # We install all desktop files by hand.
+ econf \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ --disable-desktopfiles
+}
+
+DOCS=( NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+
+ use doc && dodoc -r doc
+
+ # Install desktop files.
+ cd desktopfiles
+ for i in {22,32,48,64}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
+ newins prebuilt-hi${i}-djvu.png image-vnd.djvu.png
+ done
+ insinto /usr/share/mime/packages
+ doins djvulibre-mime.xml
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ has_version app-text/djview || \
+ optfeature "For djviewer or browser plugin" app-text/djview
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}
diff --git a/app-text/djvu/files/djvu-3.5.24-gcc46.patch b/app-text/djvu/files/djvu-3.5.24-gcc46.patch
new file mode 100644
index 000000000000..2d1d099bfbb9
--- /dev/null
+++ b/app-text/djvu/files/djvu-3.5.24-gcc46.patch
@@ -0,0 +1,40 @@
+http://bugs.gentoo.org/361057 for GSmartPointer.h change
+
+Then include stddef.h in the installed headers to fix building of reverse
+dependencies, such as app-text/zathura-djvu
+
+These are all in upstream GIT
+
+--- a/libdjvu/ddjvuapi.h
++++ b/libdjvu/ddjvuapi.h
+@@ -64,6 +64,7 @@
+ }
+ #endif
+
++#include <stddef.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+
+--- a/libdjvu/GSmartPointer.h
++++ b/libdjvu/GSmartPointer.h
+@@ -62,6 +62,8 @@
+ # pragma interface
+ #endif
+
++#include <cstddef>
++
+ /** @name GSmartPointer.h
+
+ Files #"GSmartPointer.h"# and #"GSmartPointer.cpp"# define a smart-pointer
+--- a/libdjvu/miniexp.h
++++ b/libdjvu/miniexp.h
+@@ -38,7 +38,8 @@
+ #ifndef MINILISPAPI
+ # define MINILISPAPI /**/
+ #endif
+-
++
++#include <stddef.h>
+
+ /* -------------------------------------------------- */
+ /* LISP EXPRESSIONS */
diff --git a/app-text/djvu/metadata.xml b/app-text/djvu/metadata.xml
new file mode 100644
index 000000000000..775c1334667a
--- /dev/null
+++ b/app-text/djvu/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <longdescription>
+DjVu is a web-centric format and software platform for distributing documents
+and images. DjVu can advantageously replace PDF, PS, TIFF, JPEG, and GIF for
+distributing scanned documents, digital documents, or high-resolution pictures.
+DjVu content downloads faster, displays and renders faster, looks nicer on a
+screen, and consume less client resources than competing formats. DjVu images
+display instantly and can be smoothly zoomed and panned with no lengthy
+re-rendering. DjVu is used by hundreds of academic, commercial, governmental,
+and non-commercial web sites around the world.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">djvu</remote-id>
+ </upstream>
+</pkgmetadata>