summaryrefslogtreecommitdiff
path: root/app-text/discount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-text/discount
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/Manifest2
-rw-r--r--app-text/discount/discount-2.2.7b.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 17fdf894c646..6416079c0aec 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,4 +1,6 @@
AUX gethopt-undefined.patch 358 BLAKE2B ccc264eece330bc0c8979731410488b070c91e73381ed4f00ff95f04c5f023948f304dd70c0f8ec4ff67abf266d80ce8931fa46f53486e2e0e003f151fbda4b7 SHA512 a7504f3ab60ff49b72e475e558e128522757874d4328abf7e488313dff7c2fc3650fffc12a03109601a14348f24f21a83ed0e83f9d6fe1176207ac2692800dc1
DIST discount-2.2.7.tar.bz2 102277 BLAKE2B 58ec3bce2b8fc41a090d9b81b4326cbf54e36bf774f4f9ef63c2a2b1d34ba464e9f0a021f19b4fef165da426742af3045a631af005371d1a8a4cd81dc0be3367 SHA512 1b61eb7c625bb50da0dbe97350a0ccbb15930ccaef449c4b4659950907bce3c0564dabf20578379a7fdd0e375f5d4d5b61acd34db474a85e942b60373688bd08
+DIST discount-2.2.7b.tar.bz2 102685 BLAKE2B 1af4d47248e4a65ea1517b03d0b1a0b15eb79bdb7d1f00779515e2a1113b2a923f5d9e5d0a93d63cfc6c7257f11d3825d9baa55c7f2252fe3d2513785ab67ae3 SHA512 d68ffb85ae3e6d6ce8a2e506609bd4cb042617e350d113dd632a1ed81adb0b076df75ca4e70e97d43f3a3a2907555a9f28087a3762f41806289c526af3c55806
EBUILD discount-2.2.7-r2.ebuild 1697 BLAKE2B f6a68291682e44d6adfa9fdb40fe7e1c1bbac2c0981fd86f223344053c6510b27b4c734613c0acc4f29b31f5ffc862924ceaeda442fc7a52f27f111d6ce7e882 SHA512 cd1653e485b7785f630017210eb5268ac7c42c362cd95e2bea38f977f99c79cfd3aef8c35aa292d6764868f404bb74f77b068596a3b17c7001488c7a0c761308
+EBUILD discount-2.2.7b.ebuild 1652 BLAKE2B 1f103a53134e6efdf07f512fd512f8d88cb022d5b2592de6eed09262de304106681e145387f3df96a3a9020b417e2c220aa6b7a1005011a7a17e7eab4ee428c5 SHA512 7aea9488cb0e4ea7d5d769c115f85ee8c7f38aa4e639bc673690de6574b88be50fe86cdf37fd9749cba68160a5cd616d00ca24a2dc3a41abe695b4e2dc777044
MISC metadata.xml 245 BLAKE2B 4988fa1366a9b8a3769e503545339cdd493a0bdc362ca9237b158b94549de1f061477546b00fd3b21dc9325812423f7207071e22e3234d5c0b88c755197557d2 SHA512 e00be68ab9ad3acfce3d2d48721c47cf50e2c6358c9ceb45a2a23fc5303826ea26b9205ce4f230121c2e40c9c467367f2dc57863680899b21e8005034aa9118c
diff --git a/app-text/discount/discount-2.2.7b.ebuild b/app-text/discount/discount-2.2.7b.ebuild
new file mode 100644
index 000000000000..e496c2708756
--- /dev/null
+++ b/app-text/discount/discount-2.2.7b.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --prefix="${EPREFIX}/usr"
+ --mandir="${EPREFIX}/usr/share/man"
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ "${configure_call[@]}" || die
+}
+
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}