summaryrefslogtreecommitdiff
path: root/app-text/diff-pdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /app-text/diff-pdf
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'app-text/diff-pdf')
-rw-r--r--app-text/diff-pdf/Manifest3
-rw-r--r--app-text/diff-pdf/diff-pdf-0.3.ebuild39
-rw-r--r--app-text/diff-pdf/metadata.xml8
3 files changed, 50 insertions, 0 deletions
diff --git a/app-text/diff-pdf/Manifest b/app-text/diff-pdf/Manifest
new file mode 100644
index 000000000000..defaec75ae75
--- /dev/null
+++ b/app-text/diff-pdf/Manifest
@@ -0,0 +1,3 @@
+DIST diff-pdf-0.3.tar.gz 132862 BLAKE2B bb3fa163337482785778fa7cbeab3e9f883d8537e4a905592eb20f4bb876597f500beaa2d9f13706887e1d340dd378c68c231b91a4dd478fb206b32f2cbd768c SHA512 b85585162b498c5abf14020ad04616ebdb5efce25b20604dab81c6068a036a818d7e10ddbbdb69d278d4b5a46ab9b9aa782a52e37f278f3e9db7b4d2259aaa08
+EBUILD diff-pdf-0.3.ebuild 1284 BLAKE2B 3fac12175666e53660c24b8273ba498103cbbfca53b81b3fd5cfb83586a49d98d06ff015e5c497594f45dc9befe788784315850591a52b9ef479bbf8c5a4d6e0 SHA512 e2e620af68029e94af9905cc3545a0c864f24744a8fa31a6ffba938a87d91f078ec744dd3a8dd6620a9ae270beb19c89bea96c622345e9090f3d27d2a4599814
+MISC metadata.xml 252 BLAKE2B fa9e1dbdc0de3313b50ecd9de7ac59006074b8b75ecb97a8fc4de5fb14609cb00dc1b24ba95a2e7fb11cbc6f8c8f0c068bd0311713cc2aa7e6016992dbd6e8bd SHA512 92f660063c96ac5b3e24e58733006d4a72a7e2f41605988efb575546a2539a92b1ceb3a37e018fcb5c08264a42af26950d6520ea80ba60130ad25ce6092ce742
diff --git a/app-text/diff-pdf/diff-pdf-0.3.ebuild b/app-text/diff-pdf/diff-pdf-0.3.ebuild
new file mode 100644
index 000000000000..1f289d32bcb5
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# No EAPI=7 support in wxwidgets.eclass.
+EAPI=6
+
+inherit wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="http://vslavik.github.io/${PN}/ https://github.com/vslavik/${PN}/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:3.0[X]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ WX_GTK_VER="3.0"
+ setup-wxwidgets
+ default
+}
diff --git a/app-text/diff-pdf/metadata.xml b/app-text/diff-pdf/metadata.xml
new file mode 100644
index 000000000000..45125b9b6e99
--- /dev/null
+++ b/app-text/diff-pdf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+</pkgmetadata>