summaryrefslogtreecommitdiff
path: root/app-text/diff-pdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/diff-pdf
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/diff-pdf')
-rw-r--r--app-text/diff-pdf/Manifest2
-rw-r--r--app-text/diff-pdf/diff-pdf-0.5.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/diff-pdf/Manifest b/app-text/diff-pdf/Manifest
index f6981db9df45..31cae559d96d 100644
--- a/app-text/diff-pdf/Manifest
+++ b/app-text/diff-pdf/Manifest
@@ -1,4 +1,6 @@
AUX diff-pdf-0.4.1-no-poppler-cairo-check.patch 798 BLAKE2B f3932e5e7babd37b0df89f37536b91eee4978b3ac34b8c9e628f0db3f2d0a617f872b137cabc257e6cf470d6b80aade4c835e91310ec84b296d46d24c457f5f3 SHA512 2f4c399e482ace0e00995a732f0489d8b614e31396ed6279b0399e8c009b228386319a611ee52b784ba2313561e7aef27ae5b9090d3fb78fa09660992d483cc8
DIST diff-pdf-0.4.1.tar.gz 137715 BLAKE2B f77b7a690f2a99aa003c1a36015113f0b3355acc45346637535231f763aa733174eca6b1f962058c625e06176fa13868965b3b67ddf6ffe249202ff799051e37 SHA512 4b7b49d7008b5920be86af8398dea41933888677b66505af0ca4daecbd1662dc0b3c04e7b2631d86680cdae4b0b58d24bcd4ddc2b7589127b682d4b97a179b88
+DIST diff-pdf-0.5.tar.gz 135755 BLAKE2B e4b9599b4f443171473ef483fe868c58e0a0c9f23838895aa08f1bd662c4df920fdb50277d2d0a5b28d5bb66054e700012a98be636a12d34ec919ad85d332cc0 SHA512 62a868118fc807b433e504edfefdc6a9598a8197aaf5cd4e46451b67d5d73fcf9234bd6efbe6307ed7c3821aabef8edea81cbb0bbe5f4d34365c5f8d6dd9a51d
EBUILD diff-pdf-0.4.1-r2.ebuild 1374 BLAKE2B ca6e7afb7d7d3eccc6df6878b47ab57e7d65234bb0c8c141f1508548313093501a782b1fd83468b6a89091e5769b802fc59402c1f11c07a13f2561b9fdfbf5d0 SHA512 a4f96f2776ad48a378e2c48329d29f0ecab5cce13058cf775332d7b6c3d61e2669402819ff57310b640fa583cbada3fb9e33da2b207bd3a4430cf4cf79fa8212
+EBUILD diff-pdf-0.5.ebuild 1264 BLAKE2B 56eaf2e057acd43a1fe3ce5f388559b1db528476842f30507b053b81975b79708767308b01545c960dccb0af4e04ad6c2c0e1632c50842d591d55fc77b847eeb SHA512 11817c1ee726488713d6d02296930fb4fc2b1ce93d56dc98cbc0a9591a72e785bb9aea8592491b0b4885a81edee6132b372a4ec479e390d76819660be643cd8e
MISC metadata.xml 253 BLAKE2B 63a51cab94d3e978d2c7dd1d124efd1c9e11c5ae277806a1f12359b2db370c37382fc1947e85940f6b0a439e3d49eecdd8d9bfb96587352d6a83803d2fd40bb6 SHA512 8da7cfe0cd26a54c106f2c029bbde93abf77576835e4fa66bc538dcf12fd41160f7cc2dd843a221962bb9a6f965311c076a1557caa38d503f371569b84841e33
diff --git a/app-text/diff-pdf/diff-pdf-0.5.ebuild b/app-text/diff-pdf/diff-pdf-0.5.ebuild
new file mode 100644
index 000000000000..20cd79c43238
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="https://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ setup-wxwidgets
+ default
+}