summaryrefslogtreecommitdiff
path: root/app-text/dblatex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
commitaafdd1dcd9a66da0b1bcdfadbca62add48751897 (patch)
treed328a4fe625235ee8ea443c3b1bec1fd105af11d /app-text/dblatex
parente0345ef79b0b4a444151748ce1f5364fc2dd147b (diff)
gentoo auto-resync : 13:11:2023 - 10:28:51
Diffstat (limited to 'app-text/dblatex')
-rw-r--r--app-text/dblatex/Manifest1
-rw-r--r--app-text/dblatex/dblatex-0.3.12-r2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-text/dblatex/Manifest b/app-text/dblatex/Manifest
index 64cb71a14070..9fd10dbd726b 100644
--- a/app-text/dblatex/Manifest
+++ b/app-text/dblatex/Manifest
@@ -7,4 +7,5 @@ DIST dblatex-0.3.11py3.tar.bz2 1671505 BLAKE2B 44e89f5f8d81105a3401074ad765479c0
DIST dblatex3-0.3.12.tar.bz2 1693272 BLAKE2B 9310ce5db3b5f92e183f2656c5b1881edaf0208ae4f78f853332c844258fa38d443921fc42c03301773b1451ce272a538c305d765acbdc6eafbdcf25ebf5d2d3 SHA512 5bfa774c8dbe362775f6bbb5e1196e5a2bb1af239778133c12ddc725406ced67f3ff422433a2a1aa02d4431e9be58ba12e918379deb81fcd5b96533d2bdf029a
EBUILD dblatex-0.3.11-r1.ebuild 1827 BLAKE2B 34b52a951121ede45a6068422fcd3348b98fe3f5b764fa2eaa463a837c260a0dc881ffdfa7b2d63464062b1214e12f34a0ccf4c2b78942b81944b74ad86d1b9c SHA512 7c760c2e1caeb089c1b038535ee849becee4ce06fc9634a3c382b2f518ef81d60a9ab5869ca22f44efbc42dcb6be73d2d5237ea6940732bf09ce5fd793a0ca50
EBUILD dblatex-0.3.12-r1.ebuild 1977 BLAKE2B c63e95a6027a96e34b389abdbb5e51c51933e0d445e2786f97609e72c25b3827dff2eee311e53cf5075f7d15e967de4c9a35077f25de67b5675052bc334f06e4 SHA512 a0c0e50ad18bd39a234840fcd042f49a89184b850a0d33ba5304190f1f2a0900e5135a3f71ca6b26b3ed204e31279f0cd6d244af2ac1ddca4a350a90f900ea98
+EBUILD dblatex-0.3.12-r2.ebuild 1994 BLAKE2B 545978061d3ba41aa2ebbb5c0efa3865b9092cfa57adcc996dcfd9d8bbed399870fa55f6e71e5616d94dd16154434412cbd958b6765fd5b3da903053c9b5f1fd SHA512 0dae24c047bdce482a60edd3e53454452bfcb353129908d6ffdf71f30ddb4f1f5db143f6edad89576d6b39ea1e3eae94221034a2626ca79eb3b754f0920edb49
MISC metadata.xml 908 BLAKE2B e13f176739b3fb7a63a5eaeb704afa1c0b4e9740ea25dec54656c283cf9f8f614096aae407df8822414e054eaad0082c738c0a5a2acc91a51ce3f6b729fc37d6 SHA512 a39c4073b4cec1753724d16bcca023c9306eeac79bc7f008c6e090f85c4661733810c9864b91b9552fbbec242c01a312780ee780d11724ce26399bad3c9a0899
diff --git a/app-text/dblatex/dblatex-0.3.12-r2.ebuild b/app-text/dblatex/dblatex-0.3.12-r2.ebuild
new file mode 100644
index 000000000000..6902a9a37b05
--- /dev/null
+++ b/app-text/dblatex/dblatex-0.3.12-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+# Breaks installation of /usr/bin/dblatex, bug #906788
+#DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Transform DocBook using TeX macros"
+HOMEPAGE="http://dblatex.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/dblatex/dblatex/${P}/${PN}3-${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="inkscape test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/kpathsea
+ dev-libs/libxslt
+ dev-libs/libxslt
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-xetex
+ gnome-base/librsvg
+ media-gfx/imagemagick
+ >=media-gfx/fig2dev-3.2.9-r1
+ inkscape? ( media-gfx/inkscape )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ test? ( ~${CATEGORY}/${P} )"
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.11-path-logging.patch"
+ "${FILESDIR}/${PN}-0.3.11-setup.patch"
+ "${FILESDIR}/${PN}-0.3.11-encode.patch"
+)
+
+python_prepare_all() {
+ # Manual page is precomressed, but we will use our own compression later.
+ gunzip docs/manpage/dblatex.1.gz || die
+ # If we dont have inkscape we need to use an alternative SVG converter
+ use inkscape || eapply "${FILESDIR}/${PN}-0.3.11-no-inkscape-dependency.patch"
+ # If we use inscape however we want to make dblatex compatible with v1.0
+ use inkscape && eapply "${FILESDIR}/${PN}-0.3.11-inkscape-1.0.patch"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Move package documentation to a folder name containing version number
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+}
+
+python_test_all() {
+ emake -C tests/mathml
+}