summaryrefslogtreecommitdiff
path: root/app-text/dbacl/dbacl-1.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/dbacl/dbacl-1.14.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/dbacl/dbacl-1.14.ebuild')
-rw-r--r--app-text/dbacl/dbacl-1.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/dbacl/dbacl-1.14.ebuild b/app-text/dbacl/dbacl-1.14.ebuild
new file mode 100644
index 000000000000..1d92922bbae4
--- /dev/null
+++ b/app-text/dbacl/dbacl-1.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Digramic Bayesian text classifier"
+HOMEPAGE="http://www.lbreyer.com/gpl.html"
+SRC_URI="http://www.lbreyer.com/gpl/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 s390 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="interactive"
+
+RDEPEND="interactive? (
+ sys-libs/slang:=
+ sys-libs/readline:=
+ sys-libs/ncurses:= )"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # See bug #352636 for reference
+ export ac_cv_lib_ncurses_initscr=$(usex interactive)
+ export ac_cv_lib_readline_readline=$(usex interactive)
+ export ac_cv_lib_slang_SLsmg_init_smg=$(usex interactive)
+}