summaryrefslogtreecommitdiff
path: root/app-text/crengine-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-03 14:26:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-03 14:26:22 +0000
commit5aede38e7304fc5c3bd8a2034b25758b15a19fa0 (patch)
tree95f6b79a072854ddd86f7932f876acb7fbaf7752 /app-text/crengine-ng
parent2f28d79786e67cf29825843d6d04d4591a27f9cf (diff)
gentoo auto-resync : 03:01:2023 - 14:26:21
Diffstat (limited to 'app-text/crengine-ng')
-rw-r--r--app-text/crengine-ng/Manifest3
-rw-r--r--app-text/crengine-ng/crengine-ng-0.9.4-r1.ebuild (renamed from app-text/crengine-ng/crengine-ng-0.9.4.ebuild)4
-rw-r--r--app-text/crengine-ng/files/crengine-ng-0.9.4.patch55
3 files changed, 60 insertions, 2 deletions
diff --git a/app-text/crengine-ng/Manifest b/app-text/crengine-ng/Manifest
index f1ec490fbbe0..00d103cb39bd 100644
--- a/app-text/crengine-ng/Manifest
+++ b/app-text/crengine-ng/Manifest
@@ -1,3 +1,4 @@
+AUX crengine-ng-0.9.4.patch 1408 BLAKE2B 8a770656dc7b08f7c10fc945beca7ae19a851aa5d1c4aaa25541e29bf6851ffdfb4ecb53e6325539f5318534fc369a78b84849941ee8d73842132228f7fcfbd4 SHA512 ec9cc3de6c4ff46118f2ada8db3f4064cc17bba0dbc3e4b3c876aa1c71aa7da1594a45c2a88d42474f06cfc4c02a504f1ee1edc4224e8e3c6bd541c78fde876d
DIST crengine-ng-0.9.4.tar.bz2 3566778 BLAKE2B ded7b6b620ad8d24c65d45b166b08b3f74f1d68d67920e7ba9665570e3fef9d9bee9032e683ad8b0eab31fb12bc2ac03390e9ef0cd46702f28c78d5aff54a728 SHA512 491046d44088842a454c58ba71a2b5ce69e4692e4d1e16f082c096936f776c6ea9fd70ae93251348cff36ed46e5ad7991cc64099c5f313acb17e35ca08ea2698
-EBUILD crengine-ng-0.9.4.ebuild 1604 BLAKE2B 5a58df581a2e0c326601de20e766240b194f73a8f38c42b1de0783c36a2f36f2431fdacdfccea694bcf5a5c3c5c4abbb690ecdf4cef1aef63bc1b0ff7b86e3c4 SHA512 34ba53829325903c482e23b6c9b8c99f407bf30c1a2b618da60645508cc8f79dbc1172f08de041734b632a64443a8fb24c9e72aa6fbbddd321369244580f5b5c
+EBUILD crengine-ng-0.9.4-r1.ebuild 1642 BLAKE2B dbb5573307b258e0a6ea961761365b85c5a5ffbd310cfeebe5efd779940d7a3c35162b35789343b92a02324024bd5e50410acb551cc75064e16d4ebde42b15af SHA512 b5f28f68bcd54f92924f9c78c2b962e5752e91b0b9ea2f10fcc41e1f55ebabf1a7b3890719d13bd5f3d2522e5992c5b871d84ce2efbefd6928f9674255e93125
MISC metadata.xml 1232 BLAKE2B ecb2f3ff8720e43b48f6e211da27f0f34d3123644a429cb7853ae4044761793f5137dfbeaa0962093f2b722fdcfb6e3bf9ad432835fa6fa3f5bbf5f7f7abd78c SHA512 6aa7904c0d002926d4223c46b31de30f5ab06dee8291909498ecaa6deed3a6b547cfaa40df1ad7dca7e74faa55e95ab4fe4fa4ac0698202b5dd0221a50288036
diff --git a/app-text/crengine-ng/crengine-ng-0.9.4.ebuild b/app-text/crengine-ng/crengine-ng-0.9.4-r1.ebuild
index f17cdaadf91a..75782c9ba4db 100644
--- a/app-text/crengine-ng/crengine-ng-0.9.4.ebuild
+++ b/app-text/crengine-ng/crengine-ng-0.9.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
${CDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
src_configure() {
CMAKE_USE_DIR="${S}"
CMAKE_BUILD_TYPE="Release"
diff --git a/app-text/crengine-ng/files/crengine-ng-0.9.4.patch b/app-text/crengine-ng/files/crengine-ng-0.9.4.patch
new file mode 100644
index 000000000000..227071816d5b
--- /dev/null
+++ b/app-text/crengine-ng/files/crengine-ng-0.9.4.patch
@@ -0,0 +1,55 @@
+From 62106833d4e8af5325ed7a55c7a897e43a52bb20 Mon Sep 17 00:00:00 2001
+From: Aleksey Chernov <valexlin@gmail.com>
+Date: Sun, 1 Jan 2023 09:55:04 +0400
+Subject: [PATCH] Compile warnings/errors fixed: `strcasecmp` missing
+ prototype.
+
+---
+ thirdparty/antiword/antiword.h | 3 +++
+ thirdparty/chmlib/src/chm_lib.c | 6 +-----
+ 2 files changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/thirdparty/antiword/antiword.h b/thirdparty/antiword/antiword.h
+index e6f4d68f..0abce7af 100644
+--- a/thirdparty/antiword/antiword.h
++++ b/thirdparty/antiword/antiword.h
+@@ -31,6 +31,9 @@
+ #else
+ #include <sys/types.h>
+ #endif /* __riscos */
++#include <string.h>
++#include <strings.h>
++
+ #include "wordconst.h"
+ #include "wordtypes.h"
+ #include "fail.h"
+diff --git a/thirdparty/chmlib/src/chm_lib.c b/thirdparty/chmlib/src/chm_lib.c
+index 637a32b2..2e26db1e 100644
+--- a/thirdparty/chmlib/src/chm_lib.c
++++ b/thirdparty/chmlib/src/chm_lib.c
+@@ -59,6 +59,7 @@
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #ifdef CHM_DEBUG
+ #include <stdio.h>
+ #endif
+@@ -70,14 +71,9 @@
+ #ifdef WIN32
+ #include <windows.h>
+ #include <malloc.h>
+-#ifdef _WIN32_WCE
+ #define strcasecmp _stricmp
+ #define strncasecmp _strnicmp
+ #else
+-#define strcasecmp _stricmp
+-#define strncasecmp _strnicmp
+-#endif
+-#else
+ /* basic Linux system includes */
+ #define _XOPEN_SOURCE 500
+ #include <unistd.h>
+--
+2.37.4
+