summaryrefslogtreecommitdiff
path: root/app-text/cpdf/cpdf-2.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/cpdf/cpdf-2.1.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/cpdf/cpdf-2.1.1-r1.ebuild')
-rw-r--r--app-text/cpdf/cpdf-2.1.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/cpdf/cpdf-2.1.1-r1.ebuild b/app-text/cpdf/cpdf-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..74a530638f33
--- /dev/null
+++ b/app-text/cpdf/cpdf-2.1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="http://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# BSD is only for xmlm.ml
+LICENSE="Coherent-Graphics BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=
+ dev-ml/camlpdf:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}-source-${PV}
+
+src_compile() {
+ # parallel make issues
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+
+ dobin cpdf
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc cpdfmanual.pdf
+ dohtml doc/cpdf/html/*
+ fi
+}