summaryrefslogtreecommitdiff
path: root/app-text/coolreader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/coolreader
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/coolreader')
-rw-r--r--app-text/coolreader/Manifest5
-rw-r--r--app-text/coolreader/coolreader-3.1.2.71-r2.ebuild60
-rw-r--r--app-text/coolreader/files/cr3.1.2.71-r1_qt5_wx.diff242
-rw-r--r--app-text/coolreader/files/cr3ini.diff35
-rw-r--r--app-text/coolreader/metadata.xml14
5 files changed, 356 insertions, 0 deletions
diff --git a/app-text/coolreader/Manifest b/app-text/coolreader/Manifest
new file mode 100644
index 000000000000..29b19235a9f0
--- /dev/null
+++ b/app-text/coolreader/Manifest
@@ -0,0 +1,5 @@
+AUX cr3.1.2.71-r1_qt5_wx.diff 10066 SHA256 54090908b2e20a33888a85cf8d5a371b624c54a002ea164b1a01ff5cfe856838 SHA512 9f7a82964d1f5c308ad5124433dd0ed7debd715f1c0c2431bc84c9bf71d1d5dbbfb82a669b1c6ee114196c5e8ba1b745b07cc2195d4198c664ea15cf82182384 WHIRLPOOL b6e586e1179d9acd0e584591db3c65b6a9151e1f148154b15f20fef0ed4f7001747b66fe6db97d2a5e098f718c764991dbc6ac302132fc10a6b30a2815d60336
+AUX cr3ini.diff 1535 SHA256 8028aaf8bb1b3dbf0d48333240f83bbb9ef1b71a344b1ddce4bbe47cd9c35f29 SHA512 efd7bfda3617168bda2bfad9e561b7bf3de89f141cf4155618bc6864fa5497d5b0e08ea583b302f4e9e3f60442472c7e5358313dd49549dce3fe078d58ee4ee5 WHIRLPOOL 5f2128c8acfd9900dca9a0197857c97cb84bdb221a9edb81e4fe73c910c0a8eceaa645e310b6d6bb8034cf8119086e90d857ff5d702c545a13cdeb80892b4b4b
+DIST coolreader-3.1.2.71.tar.bz2 10141514 SHA256 746345984be549284713a450686f0c8b04f1485f9a28bedc457940ea1b52f7d1 SHA512 2859eabfc8ba603d1cb09b07358887135b6968268a5f2fa7f874a1e8613d1b5ebe69d9b133f16e84321d1a460eae5088a7947433c6fb340a47bde9ceee415735 WHIRLPOOL b8a8bb58c811592577dc4e1b9b1ae0ed0a3dd92e277b1501962d2c7683c0969b49f71fa147c445f7985cf82bea6431a818915bdf2387f48831fab70defdf42c7
+EBUILD coolreader-3.1.2.71-r2.ebuild 1769 SHA256 cc0542f20a22c3100b8a364de0dedfe0a39952924bf6ff93081c17cbb23e5d73 SHA512 ba1db10c44e2cd8ad697596264d041c3eafad8ea82fda1878ac6077696e928b3e2b3ac335f63878d7849ffbecd66ff5a220f64e3425315c5f1520176c842d0bb WHIRLPOOL 203159595225b5c3679757e58d3f77f25fe9f867b3211ab4b33be68df60d02c965edd1a820c9f0c1bd3addd0c965411881770a807e45fe3334fbd8464d663d56
+MISC metadata.xml 528 SHA256 f8cff5008df71398dab0c06b9158da710af074b900e702e40395d0474ba54b57 SHA512 7cca7abbe95fc510c91f0c3b4db45257b00dd5497c1f978e398d4e5a7dcd8238e9056b4980eaa9e4cbd97cda9b5781186f87301df17383b051a876d0974cbf8f WHIRLPOOL 5086b2a5c9164b565f8e8b727821ce41c979d35b239f68541a4fb2ba1efdf6d4e8338ecca493a9f921b8d7a206c51c3888f6f5f234e6ba455126d5841daecca1
diff --git a/app-text/coolreader/coolreader-3.1.2.71-r2.ebuild b/app-text/coolreader/coolreader-3.1.2.71-r2.ebuild
new file mode 100644
index 000000000000..afcc1ac458be
--- /dev/null
+++ b/app-text/coolreader/coolreader-3.1.2.71-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+if [ "${PV}" == 9999 ]
+then
+ inherit git-r3
+ # github mirror has some new commits to fix page margins settings
+ # sourceforge mirror saved as backup
+ #EGIT_REPO_URI="git://git.code.sf.net/p/crengine/crengine"
+ EGIT_REPO_URI="https://github.com/buggins/coolreader.git"
+ SRC_URI=""
+else
+ # git tag cr3.1.2-71
+ SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+fi
+
+DESCRIPTION="CoolReader - reader of eBook files (fb2,epub,htm,rtf,txt)"
+HOMEPAGE="https://sourceforge.net/projects/crengine/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="wxwidgets"
+
+DEPEND="sys-libs/zlib
+ media-libs/libpng:0
+ virtual/jpeg:0
+ media-libs/freetype
+ wxwidgets? ( || ( x11-libs/wxGTK:3.0 x11-libs/wxGTK:2.8 ) )
+ !wxwidgets? ( dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 )"
+RDEPEND="${DEPEND}
+ wxwidgets? ( || ( media-fonts/liberation-fonts media-fonts/corefonts ) )"
+
+# 1st patch: To save cr3.ini to ~homedir.
+# 2nd patch: To build QT5 and WX GUI version of coolreader3;
+# setting correct vesrion number and years of cr3qt/cr3wx;
+# internal switching between wxGTK 2.8 or 3.0 version;
+# show wxWidgets version in "About" dialog window;
+# disabling "iCCP: known incorrect sRGB profile" warning popup window for wxwidgets GUI
+
+PATCHES=( "${FILESDIR}/cr3ini.diff" "${FILESDIR}/cr3.1.2.71-r1_qt5_wx.diff" )
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ if use wxwidgets; then
+ . "${ROOT}/var/lib/wxwidgets/current"
+ if [[ "${WXCONFIG}" -eq "none" ]]; then
+ die "The wxGTK profile should be selected!"
+ fi
+ local mycmakeargs=(-D GUI=WX)
+ else
+ local mycmakeargs=(-D GUI=QT5)
+ fi
+ cmake-utils_src_configure
+}
diff --git a/app-text/coolreader/files/cr3.1.2.71-r1_qt5_wx.diff b/app-text/coolreader/files/cr3.1.2.71-r1_qt5_wx.diff
new file mode 100644
index 000000000000..434d4556da94
--- /dev/null
+++ b/app-text/coolreader/files/cr3.1.2.71-r1_qt5_wx.diff
@@ -0,0 +1,242 @@
+diff -Naur old/CMakeLists.txt new/CMakeLists.txt
+--- old/CMakeLists.txt 2017-08-30 18:31:28.000000000 +0300
++++ new/CMakeLists.txt 2017-09-02 23:43:38.000000000 +0300
+@@ -29,7 +29,7 @@
+ endif()
+ elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+ # Update if necessary
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -pedantic")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -pedantic -std=c++11 -fPIC")
+ endif()
+
+ if (NOT DEFINED GUI)
+@@ -323,7 +323,7 @@
+ message("Will make CR3/WX")
+ ADD_DEFINITIONS( ${DESKTOP_DEFS} -DCR_WX_SUPPORT=1 )
+ SET(wxWidgets_USE_LIBS base core )
+- FIND_PACKAGE(wxWidgets)
++ FIND_PACKAGE(wxWidgets 2.8)
+ IF (wxWidgets_FOUND)
+ INCLUDE(${wxWidgets_USE_FILE})
+ include_directories( ${wxWidgets_INCLUDE_DIRS} )
+diff -Naur old/cr3qt/CMakeLists.txt new/cr3qt/CMakeLists.txt
+--- old/cr3qt/CMakeLists.txt 2017-08-30 18:31:28.000000000 +0300
++++ new/cr3qt/CMakeLists.txt 2017-09-03 00:53:38.000000000 +0300
+@@ -173,7 +173,11 @@
+ SET (EXTRA_LIBS ${QT_LIBRARIES} ${STD_LIBS} )
+ #${QT_LIBRARIES}
+ ELSEIF (UNIX)
+- SET (EXTRA_LIBS ${QT_LIBRARIES} fontconfig ${STD_LIBS} )
++ IF( ${GUI} STREQUAL QT )
++ SET (EXTRA_LIBS ${QT_LIBRARIES} fontconfig ${STD_LIBS} )
++ ELSE()
++ SET (EXTRA_LIBS fontconfig ${STD_LIBS} ${Qt5Core_LIBRARIES} ${Qt5Widgets_LIBRARIES})
++ ENDIF()
+ ELSE()
+ SET (EXTRA_LIBS ${STD_LIBS} ${QT_LIBRARIES} ${Qt5Core_LIBRARIES} ${Qt5Widgets_LIBRARIES} )
+ ENDIF(MAC)
+diff -Naur old/cr3qt/src/aboutdlg.ui new/cr3qt/src/aboutdlg.ui
+--- old/cr3qt/src/aboutdlg.ui 2017-08-30 18:31:28.000000000 +0300
++++ new/cr3qt/src/aboutdlg.ui 2017-09-03 00:56:14.000000000 +0300
+@@ -56,7 +56,7 @@
+ <item>
+ <widget class="QLabel" name="label_2">
+ <property name="text">
+- <string notr="true">(c) 1998-2010 Vadim Lopatin</string>
++ <string notr="true">(c) 1998-2015 Vadim Lopatin</string>
+ </property>
+ </widget>
+ </item>
+diff -Naur old/cr3wx/CMakeLists.txt new/cr3wx/CMakeLists.txt
+--- old/cr3wx/CMakeLists.txt 2017-08-30 18:31:28.000000000 +0300
++++ new/cr3wx/CMakeLists.txt 2017-09-03 00:54:59.000000000 +0300
+@@ -10,7 +10,7 @@
+ )
+ LINK_DIRECTORIES(${wxWidgets_LIBRARY_DIRS})
+ ADD_EXECUTABLE(cr3 ${CR3_SOURCES})
+-SET (EXTRA_LIBS ${wxWidgets_LIBRARIES} ${STD_LIBS})
++SET (EXTRA_LIBS ${wxWidgets_LIBRARIES} fontconfig ${STD_LIBS})
+ TARGET_LINK_LIBRARIES(cr3 crengine tinydict ${EXTRA_LIBS})
+
+ IF (UNIX)
+@@ -22,6 +22,9 @@
+ INSTALL( DIRECTORY ../cr3qt/data/hyph DESTINATION share/cr3
+ FILES_MATCHING PATTERN "*.pattern" )
+ INSTALL( DIRECTORY ../cr3qt/data/skins DESTINATION share/cr3/skins )
++ INSTALL( FILES ../cr3qt/src/desktop/cr3.desktop DESTINATION share/applications )
++ INSTALL( FILES ../cr3qt/src/desktop/cr3.png DESTINATION share/pixmaps )
++ INSTALL( FILES ../cr3qt/src/desktop/cr3.xpm DESTINATION share/pixmaps )
+ ELSE()
+ INSTALL( TARGETS cr3 RUNTIME DESTINATION . )
+ INSTALL( DIRECTORY ../cr3qt/data/ DESTINATION .
+diff -Naur old/cr3wx/src/cr3.cpp new/cr3wx/src/cr3.cpp
+--- old/cr3wx/src/cr3.cpp 2017-08-30 18:31:28.000000000 +0300
++++ new/cr3wx/src/cr3.cpp 2017-09-03 02:30:35.000000000 +0300
+@@ -395,7 +395,11 @@
+
+ lString16 GetConfigFileName()
+ {
+- lString16 cfgdir( wxStandardPaths::Get().GetUserDataDir().c_str() );
++ #if wxCHECK_VERSION(3, 0, 0)
++ lString16 cfgdir( wxStandardPaths::Get().GetUserDataDir().wx_str() );
++ #else
++ lString16 cfgdir( wxStandardPaths::Get().GetUserDataDir().c_str() );
++ #endif
+ if ( !wxDirExists( cfgdir.c_str() ) )
+ ::wxMkdir( wxString( cfgdir.c_str() ) );
+ lChar16 slash = detectSlash( cfgdir );
+@@ -520,6 +524,7 @@
+
+ wxBitmap cr3Frame::getIcon16x16( const lChar16 * name )
+ {
++ wxLogNull logNo; // Temporary disable warnings ( see: http://trac.wxwidgets.org/ticket/15331 )
+ lString16 dir;
+ if ( _toolbarSize==2 )
+ dir = "icons/22x22/";
+@@ -531,7 +536,7 @@
+ if ( icon.IsOk() )
+ return icon;
+ return wxNullBitmap;
+-}
++} // ~wxLogNull called, old log sink restored
+
+ #if (USE_FREETYPE==1)
+ bool getDirectoryFonts( lString16Collection & pathList, lString16 ext, lString16Collection & fonts, bool absPath )
+@@ -622,7 +627,11 @@
+ wxImage::AddHandler(new wxPNGHandler);
+ resources = new ResourceContainer();
+
+- lString16 appname( argv[0] );
++ #if wxCHECK_VERSION(3, 0, 0)
++ lString16 appname( argv[0].wx_str() );
++ #else
++ lString16 appname( argv[0] );
++ #endif
+ int lastSlash=-1;
+ lChar16 slashChar = '/';
+ for ( int p=0; p<(int)appname.length(); p++ ) {
+@@ -777,7 +786,11 @@
+ int argc = wxGetApp().argc;
+ lString16 fnameToOpen;
+ for ( int i=1; i<argc; i++ ) {
+- lString16 param = lString16( wxGetApp().argv[1] );
++ #if wxCHECK_VERSION(3, 0, 0)
++ lString16 param = lString16( wxGetApp().argv[1].wx_str() );
++ #else
++ lString16 param = lString16( wxGetApp().argv[1] );
++ #endif
+ if ( param[0]!='-' )
+ fnameToOpen = param;
+ }
+@@ -1193,7 +1206,11 @@
+ lString16 outFile;
+ bool convert = false;
+ for ( int i=1; i<argc; i++ ) {
+- lString16 param = lString16( wxGetApp().argv[i] );
++ #if wxCHECK_VERSION(3, 0, 0)
++ lString16 param = lString16( wxGetApp().argv[i].wx_str() );
++ #else
++ lString16 param = lString16( wxGetApp().argv[i] );
++ #endif
+ if ( param[0]!='-' )
+ fnameToOpen = param;
+ else if (param.startsWith("--convert"))
+@@ -1470,7 +1487,11 @@
+ wxCursor hg( wxCURSOR_WAIT );
+ this->SetCursor( hg );
+ wxSetCursor( hg );
+- _view->getDocView()->exportWolFile( dlg.GetPath(), opts.getMode()==0, opts.getLevels() );
++ #if wxCHECK_VERSION(3, 0, 0)
++ _view->getDocView()->exportWolFile( dlg.GetPath().wx_str(), opts.getMode()==0, opts.getLevels() );
++ #else
++ _view->getDocView()->exportWolFile( dlg.GetPath(), opts.getMode()==0, opts.getLevels() );
++ #endif
+ wxSetCursor( wxNullCursor );
+ this->SetCursor( wxNullCursor );
+ }
+@@ -1479,7 +1500,7 @@
+ void
+ cr3Frame::OnAbout( wxCommandEvent& WXUNUSED( event ) )
+ {
+- wxMessageBox( wxT( "Cool Reader " wxT(CR3_VERSION) wxT("\n(c) 1998-2007 Vadim Lopatin\nwxWidgets version\n") )
++ wxMessageBox( wxT( "Cool Reader " wxT(CR3_VERSION) wxT("\n(c) 1998-2015 Vadim Lopatin\n" wxVERSION_STRING"\n") )
+ wxT("\nBased on CREngine library " wxT(CR_ENGINE_VERSION) )
+ wxT("\nThird party libraries used:")
+ wxT("\nzlib, libpng, libjpeg, freetype2,")
+diff -Naur old/cr3wx/src/optdlg.cpp new/cr3wx/src/optdlg.cpp
+--- old/cr3wx/src/optdlg.cpp 2017-08-30 18:31:28.000000000 +0300
++++ new/cr3wx/src/optdlg.cpp 2017-09-03 02:36:51.000000000 +0300
+@@ -41,7 +41,11 @@
+ if ( v==_choices[i] )
+ tb = i;
+ if ( _storeStringValues ) {
+- props->setString( _option, lString16(_choices[tb]) );
++ #if wxCHECK_VERSION(3, 0, 0)
++ props->setString( _option, lString16(_choices[tb].wx_str()) );
++ #else
++ props->setString( _option, lString16(_choices[tb]) );
++ #endif
+ } else {
+ props->setInt( _option, tb );
+ }
+@@ -50,7 +54,11 @@
+ {
+ unsigned tb = _defvalue;
+ if ( _storeStringValues ) {
+- lString8 s8 = UnicodeToUtf8( lString16(_choices[_defvalue]) );
++ #if wxCHECK_VERSION(3, 0, 0)
++ lString8 s8 = UnicodeToUtf8( lString16(_choices[_defvalue].wx_str()) );
++ #else
++ lString8 s8 = UnicodeToUtf8( lString16(_choices[_defvalue]) );
++ #endif
+ lString16 s16 = props->getStringDef( _option, s8.c_str() );
+ wxString v = s16.c_str();
+ for ( unsigned i=0; i<_choices.GetCount(); i++ )
+diff -Naur old/cr3wx/src/view.cpp new/cr3wx/src/view.cpp
+--- old/cr3wx/src/view.cpp 2017-08-30 18:31:28.000000000 +0300
++++ new/cr3wx/src/view.cpp 2017-09-03 02:40:42.000000000 +0300
+@@ -353,7 +353,11 @@
+
+ lString16 cr3view::GetHistoryFileName()
+ {
+- lString16 cfgdir( wxStandardPaths::Get().GetUserDataDir().c_str() );
++ #if wxCHECK_VERSION(3, 0, 0)
++ lString16 cfgdir( wxStandardPaths::Get().GetUserDataDir().wx_str() );
++ #else
++ lString16 cfgdir( wxStandardPaths::Get().GetUserDataDir().c_str() );
++ #endif
+ if ( !wxDirExists( cfgdir.c_str() ) )
+ ::wxMkdir( wxString( cfgdir.c_str() ) );
+ lChar16 slash = detectSlash( cfgdir );
+@@ -667,13 +671,21 @@
+ //===========================================
+ GetParent()->Update();
+ //printf(" loading... ");
+- bool res = getDocView()->LoadDocument( fname.c_str() );
++ #if wxCHECK_VERSION(3, 0, 0)
++ bool res = getDocView()->LoadDocument( fname.wx_str() );
++ #else
++ bool res = getDocView()->LoadDocument( fname.c_str() );
++ #endif
+ //printf(" done. \n");
+ //DEBUG
+ //_docview->exportWolFile( "test.wol", true );
+ //_docview->SetPos(0);
+ if ( !res )
+- getDocView()->createDefaultDocument(lString16("File open error"), lString16("Cannot open file ") + fname.c_str() );
++ #if wxCHECK_VERSION(3, 0, 0)
++ getDocView()->createDefaultDocument(lString16("File open error"), lString16("Cannot open file ") + fname.wx_str() );
++ #else
++ getDocView()->createDefaultDocument(lString16("File open error"), lString16("Cannot open file ") + fname.c_str() );
++ #endif
+ lString16 title = getDocView()->getAuthors();
+ if ( !title.empty() && !getDocView()->getTitle().empty() )
+ title << L". ";
+diff -Naur old/crengine/include/cr3version.h new/crengine/include/cr3version.h
+--- old/crengine/include/cr3version.h 2017-08-30 18:31:28.000000000 +0300
++++ new/crengine/include/cr3version.h 2017-09-03 00:55:28.000000000 +0300
+@@ -1,2 +1,2 @@
+-#define CR_ENGINE_VERSION "3.1.2-52"
+-#define CR_ENGINE_BUILD_DATE "2014-11-19"
++#define CR_ENGINE_VERSION "3.1.2-71"
++#define CR_ENGINE_BUILD_DATE "2015-07-02"
diff --git a/app-text/coolreader/files/cr3ini.diff b/app-text/coolreader/files/cr3ini.diff
new file mode 100644
index 000000000000..66562aa836a7
--- /dev/null
+++ b/app-text/coolreader/files/cr3ini.diff
@@ -0,0 +1,35 @@
+# Patch to allow creating cr3.ini file in the home directory of user
+# instead to trying save it in /usr/share/cr3/cr3.ini
+# Bug: https://sourceforge.net/p/crengine/bugs/179/
+# Patch was proposed by "Olexandr" (see bug report)
+diff --git a/cr3qt/src/mainwindow.cpp b/cr3qt/src/mainwindow.cpp
+index 142242a..0401f71 100644
+--- a/cr3qt/src/mainwindow.cpp
++++ b/cr3qt/src/mainwindow.cpp
+@@ -77,8 +77,8 @@ MainWindow::MainWindow(QWidget *parent)
+ #endif
+ QString cacheDir = homeDir + "cache";
+ QString bookmarksDir = homeDir + "bookmarks";
+- QString histFile = exeDir + "cr3hist.bmk";
+- QString histFile2 = homeDir + "cr3hist.bmk";
++ QString histFile2 = exeDir + "cr3hist.bmk";
++ QString histFile = homeDir + "cr3hist.bmk";
+ QString iniFile2 = exeDir + "cr3.ini";
+ QString iniFile = homeDir + "cr3.ini";
+ QString cssFile = homeDir + "fb2.css";
+@@ -92,9 +92,13 @@ MainWindow::MainWindow(QWidget *parent)
+ ldomDocCache::init( qt2cr( cacheDir ), DOC_CACHE_SIZE );
+ ui->view->setPropsChangeCallback( this );
+ if ( !ui->view->loadSettings( iniFile ) )
+- ui->view->loadSettings( iniFile2 );
++ if ( !ui->view->loadSettings( iniFile2 ) )
++ ui->view->saveSettings( iniFile );
++
+ if ( !ui->view->loadHistory( histFile ) )
+- ui->view->loadHistory( histFile2 );
++ if ( !ui->view->loadHistory( histFile2 ) )
++ ui->view->saveHistory( histFile );
++
+ if ( !ui->view->loadCSS( cssFile ) )
+ ui->view->loadCSS( cssFile2 );
+ #if ENABLE_BOOKMARKS_DIR==1
diff --git a/app-text/coolreader/metadata.xml b/app-text/coolreader/metadata.xml
new file mode 100644
index 000000000000..afd1b4bc9da9
--- /dev/null
+++ b/app-text/coolreader/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ A fast and small cross-platform XML/CSS based eBook reader for desktops and handheld devices.
+ Supported formats: FB2, TXT, RTF, DOC, TCR, HTML, EPUB, CHM, PDB, MOBI.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">crengine</remote-id>
+ </upstream>
+</pkgmetadata>