summaryrefslogtreecommitdiff
path: root/app-text/code2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/code2html
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/code2html')
-rw-r--r--app-text/code2html/Manifest6
-rw-r--r--app-text/code2html/code2html-0.9.1-r2.ebuild43
-rw-r--r--app-text/code2html/files/code2html-0.9.1-prefix.patch30
-rw-r--r--app-text/code2html/files/code2html-0.9.1-scalar.patch20
-rw-r--r--app-text/code2html/metadata.xml10
5 files changed, 109 insertions, 0 deletions
diff --git a/app-text/code2html/Manifest b/app-text/code2html/Manifest
new file mode 100644
index 000000000000..2a17dd47fbc6
--- /dev/null
+++ b/app-text/code2html/Manifest
@@ -0,0 +1,6 @@
+AUX code2html-0.9.1-prefix.patch 1393 BLAKE2B 84fc0e9c60772dab33ddee16fe62e96c36c321a92b973006aef6238a78a8aa7d769b14fe8e74fc993112ce7ff227876b8db467e3c10b60ccadab4f26f8b80a0c SHA512 3331c0590e992b098548cc10deffc270b4ed7cb790b747124a2053ba8a96274bcdaa08eaf8513f24a6ec8d9fb6b9bb93f8690a55d00e767085c005dc2e5f7ca4
+AUX code2html-0.9.1-scalar.patch 1435 BLAKE2B aff200017e0cb68ce17a9d8f7ee7eee6576cec4002b04ff4022f37232267169130fe1ab438258daf8f5a32283d99d4911e1203baa02b71486c9da3aef6c35632 SHA512 5e7124876b2888b24792d351d958efc09daee90422cf457a2a820920d6185df0d53dbd68f79acb084e4b4fed45fece8dcfc642ae94f0def78567e4f8366022b6
+DIST code2html-0.9.1-gentoo_patches.tar.bz2 2666 BLAKE2B 31c750aae9dbe9eddc77840a70535a5a6f1d495aa2015efe4afbded2481f2b7b171a95ab20ffcafd38a953170a6da0e8ccf895fded432ca7a16de6cdbc0d58d0 SHA512 cd478b53f0c11b9b4838a842bd8cb344698c85b1c3e09f03a75214f4002f4748a15f995530d6b6c743a4edb784c8aa703786ec10d3bda971b9485153e7090fdc
+DIST code2html-0.9.1.tar.gz 39811 BLAKE2B 57724d636d53066458b806266fc0a61e44919608ad44d65c540d0b6442e93acd822fcdc68c6c3279614b0887a9b7e6553e2de2c1a27679bd34c971ad1a05d70b SHA512 97fb8cadfe64a389711c58b13b7b5d977849f3a242c32a2456f93d7abd39f5d0a4152416f5c73aa05f151316ea0d8486b2b9923a5390eefec3e9d8253cc0b2d3
+EBUILD code2html-0.9.1-r2.ebuild 1024 BLAKE2B bdd4d69c61559aa2ae33573810cb7472ac10a8ee6acaf3e8d8aa0014415909ab559495548bd535a76c901f60d7cee403a5dc19e3d3705f31f0f1b00338583fc5 SHA512 17b5612546ef90b77cbaa14f3da9820dda7c7a11da5b7cf1d760b829aaafb14cd2b89bd8f5d3d8b5c3c1a0b34e3c72e12d380ad047decf3bacdd1a1831765a35
+MISC metadata.xml 363 BLAKE2B 7c3380eb1a4e1f2e83e72891a54030ee93e271468afff70a22034736f9a62475f2b275f8ec47b2e4d10de4aa5590987a04db1f0ea64b17b07bf163ced3a6ef3f SHA512 52e56f49ca7fa6b899f18be6602bd2e1c2987e5a4663593cc2e857a47e0f55637585801e656f79029e68d277a2b89d83f27953644fc778f6e7d425e2c3adb00f
diff --git a/app-text/code2html/code2html-0.9.1-r2.ebuild b/app-text/code2html/code2html-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..fbcb1710f60b
--- /dev/null
+++ b/app-text/code2html/code2html-0.9.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils prefix
+
+DESCRIPTION="Converts source files to colored HTML output"
+HOMEPAGE="http://www.palfrader.org/code2html/"
+SRC_URI="http://www.palfrader.org/code2html/all/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo_patches.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5"
+
+src_prepare() {
+ # Be consistent in color codes (bug #119406)
+ epatch "${WORKDIR}"/${P}-lowercase_color_codes.patch
+
+ # Improved C++ support (bug #133159)
+ epatch "${WORKDIR}"/${P}-cpp_keywords.patch
+
+ # Improved Ada support (bug #133176)
+ epatch "${WORKDIR}"/${P}-ada_identifiers.patch
+
+ # For prefix paths
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify code2html
+
+ # For newer Perl, bug 523610
+ epatch "${FILESDIR}"/${P}-scalar.patch
+}
+
+src_install() {
+ dobin code2html
+ dodoc ChangeLog CREDITS README
+ doman code2html.1
+}
diff --git a/app-text/code2html/files/code2html-0.9.1-prefix.patch b/app-text/code2html/files/code2html-0.9.1-prefix.patch
new file mode 100644
index 000000000000..cc27296fb71c
--- /dev/null
+++ b/app-text/code2html/files/code2html-0.9.1-prefix.patch
@@ -0,0 +1,30 @@
+--- code2html
++++ code2html
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!@GENTOO_PORTAGE_EPREFIX@/usr/bin/perl -w
+ use locale;
+ my $vernr = "0.9.1";
+ my $monthshort = "Jan";
+@@ -45,9 +45,9 @@
+ # PP: A hash would be nicer but then it would not possible to get the keys in this very order (AFAIK)
+ # PP: If names contain meta characters, then those must be metaquoted (if you don't want the meta chars to be meta chars of course)
+ my @CGI_ENCODING = (
+- ['bzip2' , '/usr/bin/bzip2' , '--stdout' ],
+- ['gzip' , '/bin/gzip' , '--stdout' ],
+- ['compress' , '/usr/bin/compress' , '-c' ]
++ ['bzip2' , '@GENTOO_PORTAGE_EPREFIX@/usr/bin/bzip2' , '--stdout' ],
++ ['gzip' , '@GENTOO_PORTAGE_EPREFIX@/bin/gzip' , '--stdout' ],
++ ['compress' , '@GENTOO_PORTAGE_EPREFIX@/usr/bin/compress' , '-c' ]
+ );
+
+
+@@ -147,7 +147,7 @@
+ # building up the database
+ # newer entries overwrite old ones
+ my @CONFIG_FILES;
+- push @CONFIG_FILES, "/etc/code2html.config";
++ push @CONFIG_FILES, "@GENTOO_PORTAGE_EPREFIX@/etc/code2html.config";
+ push @CONFIG_FILES, $ENV{'HOME'}."/.code2html.config" if (defined($ENV{'HOME'}));
+ push @CONFIG_FILES, split(/:/,$ENV{'CODE2HTML_CONFIG'}) if ($ENV{'CODE2HTML_CONFIG'});
+ push @CONFIG_FILES, split(/:/,$params{'langfile'}) if defined($params{'langfile'});
diff --git a/app-text/code2html/files/code2html-0.9.1-scalar.patch b/app-text/code2html/files/code2html-0.9.1-scalar.patch
new file mode 100644
index 000000000000..eddc89a6a8f7
--- /dev/null
+++ b/app-text/code2html/files/code2html-0.9.1-scalar.patch
@@ -0,0 +1,20 @@
+--- code2html.orig 2002-01-12 22:17:02.000000000 +0100
++++ code2html 2014-09-24 13:52:52.000000000 +0200
+@@ -1357,7 +1357,7 @@
+ my @lines = split ( /\n/, $_[0] );
+
+ my $nr = 0;
+- my $lengthofnr = length(@lines);
++ my $lengthofnr = length(scalar(@lines));
+ my $format = qq{<a name="$_[1]line%u">%${lengthofnr}u</a> %s\n} ;
+ join ('', map ( {$nr++; sprintf ( $format , $nr, $nr, $_ )} @lines));
+ },
+@@ -1367,7 +1367,7 @@
+ my @lines = split ( /\n/, $_[0] );
+
+ my $nr = 0;
+- my $lengthofnr = length(@lines);
++ my $lengthofnr = length(scalar(@lines));
+ my $format = qq{<a name="$_[1]line%u" href="#$_[1]line%u">%$ {lengthofnr}u</a> %s\n};
+ join ('', map ( {$nr++; sprintf ( $format , $nr, $nr, $nr, $_ )} @lines));
+ }
diff --git a/app-text/code2html/metadata.xml b/app-text/code2html/metadata.xml
new file mode 100644
index 000000000000..a669204029fc
--- /dev/null
+++ b/app-text/code2html/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>
+ Code2HTML converts a program source code to syntax highlighted
+ HTML. It may be called as a CGI script. It can also handle include
+ commands in HTML files.
+</longdescription>
+</pkgmetadata>