summaryrefslogtreecommitdiff
path: root/app-text/cmark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-text/cmark
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-text/cmark')
-rw-r--r--app-text/cmark/Manifest3
-rw-r--r--app-text/cmark/cmark-0.29.0.ebuild6
-rw-r--r--app-text/cmark/files/cmark-0.29.0-python38_tests.patch31
3 files changed, 38 insertions, 2 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index ff1a20a0f9b4..a5a20ee774dc 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1,3 +1,4 @@
+AUX cmark-0.29.0-python38_tests.patch 1136 BLAKE2B 788a0022fb2d2575ea18133f57863cd8c12958b4fb6f79ea8611c6358ed66531a3b923e9959ff2b29348a2506f5ad7b0fb7a5b4402cb299feb1c6939e1160a62 SHA512 bb07e53f4ead6022863edb738986761a1e7b5184737265166fcee9f9bc00124c71eb49643bcb4ea9d0634c08f1c1ca3916e3a4c76b0f801dd011a184bdc0f39e
DIST cmark-0.29.0.tar.gz 234545 BLAKE2B 1571cdf08f85142ff790db811b7973f2d95a7b1c8669af467cbeac1ad0907826a46f7e0e3ba717ba677746406f8372e40b9878f7810d317fa3c0e14db06dc8fb SHA512 06eb110cfd90c9e980c022b7588e28864d15a4da5d07d61ad4b27c6de47367492b9e58e9434e62b07517aa6dc484f17af13916808be3188f38c37d20cbf33112
-EBUILD cmark-0.29.0.ebuild 733 BLAKE2B 368a62d668bad1850d17989fe30d70b9f397d84fb130a9d79a6de63b04f6fbc17eaae99d059ae518e72f96ffb9974b90334dd4c7307dca3e4dde21d89ee1d8de SHA512 3bf8ad975aa548c7fa2fb2e5791af117e8d09d9b5aec53bd698a478520404556f8455b35c613f811ca319bc536aed30a24fc3f9e9671b342196c995f8823f26e
+EBUILD cmark-0.29.0.ebuild 787 BLAKE2B 027d8eb0f2f1250a6af14bf310ab2cb1a1cfb95550dbdd93205d718b98d80dc32713cb0c81c827b3af4fe37e123bb68681dd1b111c0304a6a3052c732b01920e SHA512 b22bddd41344a49b331f3ba1ed7a8ac2d5f38bdf5d89916a5576363ca89bd58c456bd0ecbfa9e50bfac9a4ab37883f9a0ddcd70416f18a4e7284e2c2c9f0d902
MISC metadata.xml 473 BLAKE2B 770f8d92e6aa0ff167733de2877fe1b244cd153875dce9116b361cdb4ee529e54de01f0841af1d1a23b54826786e784097afa993f791515a79c4a1af61b4349a SHA512 a0f0f24ee085d6d49311c08a1cb72f492cb88659a840ffdc2d01576c97b9a56b63beab6fe46a23df5331ce2fc100341283b2cf0bdb18a3861f0953f8c1331c72
diff --git a/app-text/cmark/cmark-0.29.0.ebuild b/app-text/cmark/cmark-0.29.0.ebuild
index 36fc6e99005e..a1db9210003d 100644
--- a/app-text/cmark/cmark-0.29.0.ebuild
+++ b/app-text/cmark/cmark-0.29.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,6 +19,10 @@ RESTRICT="!test? ( test )"
DEPEND="test? ( ${PYTHON_DEPS} )"
+PATCHES=(
+ "${FILESDIR}/${P}-python38_tests.patch"
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}
diff --git a/app-text/cmark/files/cmark-0.29.0-python38_tests.patch b/app-text/cmark/files/cmark-0.29.0-python38_tests.patch
new file mode 100644
index 000000000000..13cd71815941
--- /dev/null
+++ b/app-text/cmark/files/cmark-0.29.0-python38_tests.patch
@@ -0,0 +1,31 @@
+From 92697d564042d5b914048e087e4274c3c71e0055 Mon Sep 17 00:00:00 2001
+From: Christopher Fujino <christopherfujino@gmail.com>
+Date: Sun, 12 Jul 2020 16:11:42 -0700
+Subject: [PATCH] replace cgi.escape with html.escape (#656)
+
+---
+ test/normalize.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/normalize.py b/test/normalize.py
+index 6073bf01..f8ece18d 100644
+--- a/test/normalize.py
++++ b/test/normalize.py
+@@ -13,7 +13,7 @@ class HTMLParseError(Exception):
+ from html.entities import name2codepoint
+ import sys
+ import re
+-import cgi
++import html
+
+ # Normalization code, adapted from
+ # https://github.com/karlcow/markdown-testsuite/
+@@ -66,7 +66,7 @@ def handle_starttag(self, tag, attrs):
+ self.output += ("=" + '"' +
+ urllib.quote(urllib.unquote(v), safe='/') + '"')
+ elif v != None:
+- self.output += ("=" + '"' + cgi.escape(v,quote=True) + '"')
++ self.output += ("=" + '"' + html.escape(v,quote=True) + '"')
+ self.output += ">"
+ self.last_tag = tag
+ self.last = "starttag"